Introduction to Charts

Charts allow you to illustrate your workbook data graphically, which makes it easy to visualize comparisons and trends. Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to use charts effectively, you'll need to understand how different charts are used. They can be found under the Insert tab in the Charts group. Recommended Charts will pick the most suitable chart for your data automatically. However, you can select your own type. Most frequently used charts are:

Column Charts use vertical bars to represent data. They're most frequently used for comparing information.

Line Charts are ideal for showing trends making it easy to see whether values are increasing or decreasing over time.

Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to see which values make up the percentage of a whole.

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars.

Area charts are similar to line charts, except that the areas under the lines are filled in.

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, allowing you to see a variety of information at the same time. Source: GCFlearnfree.org

Let’s use ExcelPart6.xlsx and click on ChartTitle worksheet to practice this concept.

- Click on anywhere on the data to include everything on the worksheet. You can pick a specific range by selecting with your mouse as well. Be sure to include column titles and row labels.
- Click on Insert tab and hover your mouse over a Column Chart type. A column chart will be automatically placed in the same worksheet by default as shown below. For this example, click on Clustered Column under 2-D Column style.
- Once the chart is on your sheet, you will notice that Chart Tools contextual toolbar is added on the ribbon. And there are two tabs – Design and Format – associated with the toolbar.
Design Tab:

- **Chart Styles:** You can change your chart style to a different design by hovering your mouse over and preview your new style.

- **Switch Row/Column:** You can switch the way charts group your data by switching the rows and columns so the chart will group the data by genre, with columns for each year. In both cases, the chart contains the same data—it’s just organized differently.

- **Select Data:** You can change to a different set of data even after you created a chart by using this function.

- **Change Chart Type:** Use this to change your chart type to a different type.
• Move Chart: Once you are satisfied how your chart appears, you can use this command to move your chart to a new worksheet in the same workbook.

• One can use chart formatting shortcut buttons to quickly add chart elements, change the chart style, and filter the chart data as well.

- Clicking on the Plus sign will let you include/exclude the chart elements such as legend, title, etc. The same command can be found on under the Design Tab in the Chart Layout group at the beginning of the ribbon.
- Clicking on the Brush sign will let you change the Style and Color of your chart.
o Clicking on the **Filter** sign will let you filter the chart to only include the data set of your choice. After checking or unchecking the boxes, click **Apply** button so that your chart will only display the data set of your choice.

**Format Tab:** Commands under this tab has more to do changing the elements within the chart after you select those individual elements. For example, if you want to change the border color of the Title Box, click on the Title box first then hover the mouse on a different **Shape Style** to view the different color border style.

**Sparklines**

Sparklines are miniature charts that fit into a single cell. Use Sparklines to analyze and view trends in your data without creating an entire chart. Sparklines have certain advantages over charts. If you have many rows of data, a traditional chart would not appropriate to represent all of the rows, making relevant data difficult to find. But if you placed a sparkline on each row, it will be right next to its source data, making it easy to see relationships and trends for multiple data series at the same time.

There are three types of Types of sparklines:

- Line
- Column
- Win/Loss

Line and Column work the same as line and column charts. Win/Loss is similar to Column, except it only shows whether each value is positive or negative instead of how high or low the values are. All three types can display markers at important points, such as the highest and lowest points, to make them easier to read.
To create sparklines:

Generally, you will have one sparkline for each row, but you can create as many as you want in any location. Just like formulas, it's usually easiest to create a single sparkline and then use the fill handle to create sparklines for the adjacent rows. In our example, we'll create sparklines to help visualize trends in sales over time for each salesperson.

Let’s use SparkLines worksheet in the same workbook ExcelPart6.xlsx to practice. Source: GCFlearnfree.org

- Select the cells that will serve as the source data for the first sparkline. In our example, we'll select the cell range B3:G3.
- Click on Insert tab and Line in the Sparklines group as shown.

- Create Sparklines dialog box will appear. Use the mouse to select the cell where the sparkline will appear, then click OK. In our example, we'll select cell H3, and the cell reference will appear in the Location Range: field. The sparkline will appear in the specified cell: H3.

- Use Fill Handle to extend the sparklines to the rows below to see the trends on other sales data. Now the sparklines show clear trends in sales over time for each salesperson in our worksheet. Make the row height bigger to see the sparklines more prominent.

To Modify Sparklines:

Once you click on any cell that has sparklines, notice the Sparklines Toolbar appear on the ribbon with the Design tab.
Here you can change: the sparkline type (Line, Column, Win/Loss), see high/low point markers, change color of sparklines and even marker color by using the commands.

- In our example, let’s select the sparkline in cell H3 and click on High Point and Low Point check boxes in the Show group.
- Select a different style that shows the green dot for the high point and the red dot for the low point to stand out.
- Let’s change the sparkline type to Column by checking the Column from Type group.
- Notice all the high column bars look the same even though the figures are not exactly the same. To counter this drawback of the sparkline feature, click on the drop-down arrow under the Axis command.
- Notice both minimum and maximum values are “Automatic” for sparklines. Change both to set as “Same for All Sparklines”. Now your sparklines should reflect the actual data on your spreadsheet.
**Naming Cells in Excel**

A name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference, constant, formula, or table, each of which may be difficult to comprehend at first glance. For example, when you are adding up a range of cells that include first quarter sales, such as (C20:C30), compare how meaningful if you name that range as “firstquartersales” and use in the formula as follows:

Regular formula to sum up: \[ =\text{SUM}(C20:C30) \]
With the named range: \[ =\text{SUM}('firstquartersales') \]

**Syntax Requirements for Naming** *(Source: Microsoft.com)*

Be aware of the following rules when you create and edit names.

- **Valid characters**: The first character of a name must be a letter, an underscore character (_), or a backslash (\). Remaining characters in the name can be letters, numbers, periods, and underscore characters.
- **Cell references disallowed**: Names cannot be the same as a cell reference, such as Z$100 or R1C1.
- **Spaces are not valid**: Spaces are not allowed as part of a name. Use the underscore character (_) and period (.) as word separators; for example, Sales_Tax or First.Quarter.
- **Name length**: A name can contain up to 255 characters.
- **Case sensitivity**: Names can contain uppercase and lowercase letters. Excel does not distinguish between uppercase and lowercase characters in names. For example, if you created the name Sales and then create another name called SALES in the same workbook, Excel prompts you to choose a unique name.
- **NOTE**: You cannot use the uppercase and lowercase characters "C", "c", "R", or "r" as a defined name, because they are all used as a shorthand for selecting a row or column for the currently selected cell when you enter them in a Name or Go To text box. **If your data is formatted as a Table, Excel automatically names that table by using a generic pattern name such as “Table 1”**.

**Defining Names**

You can define names in three ways:

1. **Typing in the Name box in the left of the formula bar**: This is best used for creating a workbook level name for a selected range.

   ![Name Box](image)

   Let’s use *Travel Expense Log* worksheet in the same workbook to practice this concept.
   - Select cell ranges B3:F14.
   - Click in the name box and type in “sample”. After typing, hit **Enter** button to complete.
   - Now you have a cell range name – “sample” for cells B3:F14.
Let’s use this name in a formula:

- Select an empty cell, cell J3.
- Start typing the =SUM formula “=SUM” followed by the open parenthesis and the letter “s” to look for the name “sample”. The name “sample” will show up on top from the Formula AutoComplete drop-down list. Double-click on it to select it. [Alternatively, you can type in the entire word “sample”.]
- Place close parenthesis and hit Enter. You will get the sum result of those cell ranges (B3:F14) in cell J3.

2. **Select existing row and column labels:** You can use the Create from Selection command (under Formulas tab in Defined Names group) to conveniently create names from existing row and column labels by using a selection of cells in the worksheet. Let’s use Names worksheet to practice the following concept.

- On the Names worksheet, select the entire column A or block cell ranges A1:A9, and click on Create from Selection command. **Note:** If you use the range of cells, you will have to extend the cell ranges later if you add more on the named list. By using the entire column would give you a freedom of adding to or deleting from your list in later.
- Create Names from Selection box comes up. Accept to use Top row is a name and click on OK. Now you have a name “Depts”, the same as your column heading.
- Do the same for the columns with headings: Pay Period, and Holiday Type.
- You should be able to see all the names (including Table 1 and Table 2 for Chart Title and Sparklines worksheets) in the drop-down list on the name box. If your column heading has more than one word, an “underscore” will be automatically placed between those words.
3. **Clicking on the Define Name** in the **Defined Names** group will bring up **New Name** dialog box.
   This is best used for when you want more flexibility in creating names, such as specifying a local worksheet level scope or creating a name comment.
   - In the same worksheet - *Names*, select the cell ranges G2:G35.
   - **New Name** dialog box will appear.
   - Change the name of this range of cells to “Hours” in the **Name** box.
   - To specify the scope of the name, in the **Scope** drop-down list box, select Workbook or the name of a worksheet in the workbook.
   
   **NOTE**: By default, names use absolute cell references.
   
   - Click on OK.

Besides, typing the entire name out in the formula or selecting from the **Formula AutoComplete** as shown previously, you can use **Use in Formula** command in the **Defined Names** group. This command will become active after you create a name. Click on the drop-down arrow and select a defined name from a list available to include in your formula.

**Editing or Deleting Names**

You can use the **Name Manager** command in the **Defined Names** group to: create a new name, edit an existing name or delete a name. **Note**: if you delete an existing name being used in a formula, deleting that particular name here will make create an error in the cell that contains that formula.

To delete, select a name by clicking on it. Then **Delete**.
   - To select more than one name in a contiguous group, click and drag the names, or press **SHIFT** and click the mouse button for each name in the group.
   - To select more than one name in a noncontiguous group, press **CTRL** and click the mouse button for each name in the group.
   - Click Delete. You can also press the **DELETE** key. Click **OK** to confirm the deletion.
Creating a Drop-down List:

You can make a worksheet more efficient by providing drop-down lists. It is especially useful when you want users to limit the data entry what’s available in the list. User can click an arrow and then click an entry in the list. Note: You can create a drop-down list for a single cell or block of cells. You can copy and paste a list. You can also use fill-handle to copy the list to adjacent cells like a formula.

Let’s continue using the same workbook and select Timesheet to practice this concept. Things to consider before creating a drop-down list.

- It is recommended to create entries for your list in a row or a column in a separate worksheet in the same workbook. (We have this done in our workbook. The worksheet Names contains the lists we want to use.)
- You should sort your list the way you want it to appear. (Our lists are sorted.)
- You should name the block of list to use in the formula. (We have named our lists.)

Drop-down list in Settings:

Let’s create a drop-down list for pay period ending dates in cell G1.

- Click cell G1 on Timesheet worksheet.
- Click Data > Data Validation in the Data Tools group.

- On the Settings tab, in the Allow box, click List.
- Check the In-cell dropdown box.
- If it’s OK for people to leave the cell empty, check the Ignore blank box.
- In the Source box, type and equal sign (=), immediately followed by the name you gave your list above. In our case, =pay_period

![Data Validation Settings](image)
Input Message:
- Click the Input Message tab.
- If you want a message to pop up when the cell is clicked, check the Show input message when cell is selected box, and type a title and message in the boxes (up to 225 characters). If you don’t want a message to show up, clear the check box.

Error Alert:
This function is used to “stop” the user from inputting the invalid data. You will have to use it in combination with the “settings” function. Assume, in this timesheet example that you want to limit the user to input sick hours as whole numbers between numbers 1 to 8 only. You can place your limits as follows:
- Let’s create entering sick hours rule in cell range E4:E10. Select cell range E4:E10.
- Click on Data>Data Validation.
- In the Settings tab, select:
  - Whole number in the Allow section
  - Between in the Data section
  - Set minimum to 1 and maximum to 8 as shown.
- Next, click the Error Alert tab to enter your “error message” if an invalid data is placed in those cells. Under Style, using Stop will not let the user input any invalid data while Warning and Information will show the error message but will still let the user input invalid data. Make sure the Show error alert after invalid data is entered box is checked to show the Error Message. Click OK.
If invalid data is placed in those cells and if you had used the **Stop** under the **Style** to stop the user for doing so, a window will pop up and make the user correct the data until it meets the criteria.

**Track Changes & Comments**

Excel allows you to proofread or collaborate on Excel projects electronically using the **Track Changes** and **Comments** features.

**Track Changes:** Use **Track Changes** to log details about workbook changes every time that you save a workbook. This change history can help you identify any changes that were made to the data in the workbook, and you can then accept or reject those changes. Change tracking is especially useful when several users edit a workbook. When you turn on **Track Changes**, your workbook will be "shared" automatically. Shared workbooks are designed to be stored where other users can access and edit the workbook at the same time, such as a network. However, you can also track changes in a local or personal copy.

Let’s use **TrackNComments.xlsx** workbook for this exercise.

- From the **Review** tab, click the **Track Changes** command, then select **Highlight Changes** from the drop-down menu.

- The **Highlight Changes** dialog box will appear. Check the box next to **Track changes while editing**. Verify the box is checked for **Highlight changes on screen**, then click **OK**.

*When* box allows you to select – *all changes, since I last saved, not yet reviewed, or since date*. *Who* box allows you to select – *changes made by everyone, everyone but me, or individual username*. 

![Sick Hours](image_sick_hours.png)

![Highlight Changes](image_highlight_changes.png)
• If prompted, click **OK** to allow Excel to save your workbook. This action will make your workbook into “shared” mode automatically identifying with the word [shared] next to the title on top of screen.

• **Track Changes** will be turned on. A triangle and border color will appear in any cell you edit. If there are multiple reviewers, each person will be assigned a different color.

• Select cell E11 and change the content from “?” to “Tyler”.

• Hover your mouse over to cell E11 and see the track changes in a bubble message box.

• Click on the **Save** command in Quick Access Toolbar. Notice the color of the border changes to a different color.

• To test how **Track Changes** identify the multiple users, click on **File>Options>General Tab** and change the username to a different name.

• Now, select cell E14 and type in the word “Nancy”. The **Track Changes** will show a different color to identify the different user.

---

**Reviewing Changes on a Separate Worksheet:** **Tracked Changes history** lists everything in your worksheet that has been changed, including the "old value" (previous cell content) and the "new value" (current cell content) in a separate worksheet.
• Save your workbook again.
• From the Review tab, click the Track Changes command, then select Highlight Changes from the drop-down menu.
• In Highlight Changes window, click on the box next to “List changes on a new sheet”.

• The tracked changes will be listed on their own worksheet, called History with the date and time stamp in it. See below.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Action Number</td>
<td>Date</td>
<td>Time</td>
<td>Who</td>
<td>Change</td>
<td>Sheet</td>
<td>Range</td>
<td>New Value</td>
<td>Old Value</td>
<td>Action Type</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>12/16/2014</td>
<td>2:15 PM</td>
<td>milemle</td>
<td>Cell Change</td>
<td>GCF freeLearn</td>
<td>E10</td>
<td>Tyler</td>
<td>?</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>12/16/2014</td>
<td>2:22 PM</td>
<td>mms</td>
<td>Cell Change</td>
<td>GCF freeLearn</td>
<td>E14</td>
<td>Nancy</td>
<td>&lt;blank&gt;</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>12/16/2014</td>
<td>2:38 PM</td>
<td>Dawn</td>
<td>Cell Change</td>
<td>GCF freeLearn</td>
<td>E15</td>
<td>On your own</td>
<td>&lt;blank&gt;</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To accept/reject changes after reviewing:
• From the Review tab, click the Track Changes command, then select Accept/Reject Changes from the drop-down menu. A new window will pop-up. Select either Not yet reviewed or Since date and click on OK.
• Accept or Reject Changes window will pop-up. Click on Accept or Reject button to go through each changes individually or Accept All or Reject All button to accept or reject multiple actions at once.

• The tracked changes will still appear in your workbook even after accepting or rejecting changes. To remove them completely, you'll need to turn off Track Changes. From the Review tab, click Track Changes, then select Highlight Changes from the drop-down menu.
• **Highlight Changes** box will come up. Uncheck the box next to Track changes while editing...
• Click Yes to confirm that you want to turn off Track Changes and stop sharing your workbook.

**Comments:** Excel allows you to provide the feedback for a particular cell instead of editing the cell content. You don’t necessarily need to have Track Changes turned on to use comments though they are often used in combination. Let’s use the same workbook TrackNComments.xlsx.

• Select the cell where you want the comment to appear. In our example, we’ll select cell E12.
• From the Review tab, click the **New Comment** command.

• A comment box will appear. Type your comment, then click anywhere outside the box to close the comment.
• The comment will be added to the cell, represented by the red triangle in the top-right corner. The comment box will stay as long as Show All Comments command is selected in the Comments group on the ribbon. You can hide the comments box by clicking on Show All Comments. By doing so, only the red triangle indicator will be there and once you hover the mouse over the cell, the comment box will display.

**Editing comments:** You can edit the content of the comment by clicking inside the comment box or using Edit Comment command on the ribbon after you select the cell that contains the comments.
Deleting comments: Select the cell containing the comment you wish to delete. From the Review tab, click the Delete command in the Comments group. The comment will be deleted.

Finalizing and Protecting your Workbook:
It is a good idea to check your workbook before sharing that it does not include spelling errors or information you wish to keep private. You can use Spell Check and Document Inspector to assure avoiding these errors. We will use the same workbook TrackNComments.xlsx.

Check Spelling Errors:
• From the Review tab, click the Spelling command.

![Spelling dialog box](image)

• The Spelling dialog box will appear. For each spelling error in your worksheet, Spell Check offers suggestions for the correct spelling. Choose a suggestion or ignore if does not need to be corrected, then click Change to correct the error or Ignore Once to skip the word without changing it. Ignore All will skip the word without changing it and also skip all other instances of the word in your worksheet. Change All will change the current word and all other instances of the word. One can also add any word to the Dictionary by using the Add to Dictionary command so that Word will not prompt the word as an error in future.
A dialog box will appear after reviewing all spelling errors. Click OK to close Spell Check.

Protecting your Workbook:
Protecting your workbook becomes essential once it is shared among multiple users so that someone cannot delete or change data in certain cells by accident. Nor can they insert/delete columns, among other things. To prevent anyone from changing, moving, or deleting important data, you can protect certain worksheet or workbook elements. Use the same workbook TrackNComments.xlsx.

- Click on File and from the Info pane click on the drop-down arrow next to Protect Workbook.
• **Mark as Final:** Use this to discourage others from editing the workbook. Workbook will be opened as Read-Only copy for others. However, it will not prevent them from editing or deleting contents had they chosen Edit Anyway command upon opening.

• **Encrypt with Password:** It is simple but effective. Without the password, one cannot open the workbook. Passwords are case sensitive. Two ways to set your password.

1. Click on Encrypt with Password and fill in the password when Encrypt Document window pops up.

   OR

2. Click on File>Save As. Select a location you want to save your workbook. When the Save As dialog box comes up, click on the drop-down arrow on the Tools button next to the Save button. Select General Options. General Options dialog box will come up.
   - Enter password in the Password to open box. This will prevent users without password from opening the workbook just like in the first option above.
   - If you want some users to be able to modify the workbook upon opening, enter another password in the Password to modify box. Those who have the modification password will only be able to modify. The others will be forced to work with the Read-only copy. Read-only copy users will only be allowed to save as a copy if they make any changes and try to save.

   To unprotect workbook: you will have to go through above steps and delete passwords from boxes in General Options box.
• **Protect current Sheet:** This feature is especially useful if you want users to be able to have access to some parts of the worksheet yet still want to protect other parts that contain formulas, for example. You can get to this command either under **Info** pane (under **Protect Workbook**>**Protect Current Sheet**) or via the **Review** tab. Let’s assume we want to allow users to enter/modify data in cells E6:E18 but want to protect the remaining cells on sheet. By default, every cell in a worksheet is automatically locked but it does not mean these cells are protected. You must use **Protect Sheet** command to do so. Follow the steps below.

1. Select the cell range E6:E18.
2. Under the **Home** tab, in the **Cells** group, click the drop-down arrow next to the format.

3. From the menu, under the **Protection** heading, click on **Lock Cell**. By doing so, you are unlocking the cells range E6:E18 – this action will enable the users to edit/modify data in that range.

4. Go to **Review**, click on the **Protect Sheet**.
   From the dialog box, enter the password (so no one can unprotect without the password) and make sure to leave the check box for only **Select the unlocked cells** under **allow all users of this worksheet to**. One other option you may consider leaving the check box on is for **Edit objects** further down in the list. Giving this option will let the user to be able to leave comments.
To Unprotect Sheet: Right-click on the worksheet tab; then click on Unprotect Sheet command. Enter the password when prompted.

- **Protect Workbook**: This command is used to keep others from structural changes such as moving, deleting or adding sheets. To apply this rule, you can use either method below.
  1. Click on the Review tab. Then click on the Protect Workbook. OR
  2. Click on File>Info>Protect workbook>Protect workbook structure

*Protect Structure and Windows* dialog box will show up and the box for Structure will automatically be checked. Even though Password is optional, it is recommended to enter so no one can unprotect the workbook without the password.

Doing so will deactivate all commands upon right-clicking on the sheet and no one will be able to insert, delete, rename sheets, etc.