**Conditional Formatting**

This command can give you a visual analysis of your raw data to detect critical issues and identify patterns and trends by apply formatting—such as *colors, icons, and data bars*—to one or more cells based on the cell value. To detect the trend correctly over a period of time, it is recommended to exclude the column or row with *total values*. To learn this command, open *ExcelPart5.xlsx* workbook and use the worksheet *ConditionalFormatting*.

- We want to learn whether all sales people are meeting their monthly quota of $5000. We will apply the rule as - “If the value is greater than $5000, color the cell green.” By applying this rule, you’d be able to quickly see which cells contain values over $5000.
- Select the desired cells for the conditional formatting rule. In our example, *cells B3:G23*.
- From the Home tab, click the **Conditional Formatting** command. A drop-down menu will appear.
- Hover the mouse over the desired conditional formatting type, then select the desired rule from the menu that appears. In our example, we want to highlight cells that are **greater than** $5000.

A dialog box will appear. Enter the desired value(s) into the blank field. In our example, we'll enter **5000**. If you’d like to have a different **formatting**, click the drop down arrow and change the style to your choice such as “Red Text” or “Red Border”, etc.
The conditional formatting will be applied to the selected cells. In our example, it's easy to see which salespeople reached the $5000 sales goal for each month.

Multiple Conditional Formatting Rules: You can apply multiple conditional formatting rules to a cell range or worksheet, allowing you to visualize different trends and patterns in your data.

- For example, if you wanted to see how many cells in that selected data has unusually high data, use the color data bar to identify the cells. The larger the data, the longer the color bar will be. In our example, select the Purple Color Bar for the same cells B3:G23.

- The new formatting with color data bar should apply over the previous conditional formatting of values more than $5000. See below.
To remove conditional formatting:

- Click the **Conditional Formatting** command. A drop-down menu will appear.
- Hover the mouse over **Clear Rules**, and choose which rules you wish to clear. In our example, we'll select **Clear Rules from Entire Sheet** to remove all conditional formatting from the worksheet.

**View Options - Freezing Panes:**

Excel has useful tools to view content from the different parts of your workbook at the same time. They are called **freeze panes** (where you can freeze your rows and columns) and **split your worksheet**. Let's use the **Spring** worksheet in the same workbook to practice.

**Freezing Rows And/Or Columns:**

You may want to see certain rows or columns all the time in your worksheet, especially **header cells**. By freezing rows or columns in place, you'll be able to scroll through your content while continuing to view the frozen cells.

- Select the row below the row(s) you wish to freeze. In our example, we want to freeze rows 1 and 2, so we'll select row 3.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Employee</td>
<td>Registration</td>
<td>Plane Tickets</td>
<td>Taxi Fare</td>
<td>Car Rental</td>
<td>Meals</td>
</tr>
<tr>
<td>3</td>
<td>John Close</td>
<td>$923.00</td>
<td>$2,006.00</td>
<td>$652.00</td>
<td>$543.00</td>
<td>$3,029.00</td>
</tr>
<tr>
<td>4</td>
<td>John Watkins</td>
<td>$600.00</td>
<td>$1,540.00</td>
<td>$300.00</td>
<td>$450.00</td>
<td>$2,000.00</td>
</tr>
</tbody>
</table>

- Click the **View** tab on the **Ribbon**.
- Select the **Freeze Panes** command, then choose **Freeze Panes** from the drop-down menu. The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while continuing to view the frozen rows at the top.
- To unfreeze rows or columns, click the **Freeze Panes** command, then select **Unfreeze Panes** from the drop-down menu.
- If you need to freeze rows 1&2 and first column (column A) at the same time in the worksheet, place your cell selection at cell B3 then simply select the **Freeze Panes** from the drop-down menu. Note this **Freeze Panes** option is based on current selection. You will be able to scroll down while viewing the frozen 2 rows at the top and scroll to the right while viewing the first column on the left as indicated by the gray lines.
• The second choice **Freeze Top Row** on the drop-down list will only freeze the first row (row 1 only). Make the first row still visible on screen is when you apply this command.

• The last choice **Freeze First Column** will only freeze the first column regardless of where your cell selection is when you apply this command.

**Other View Options**

**Open a New Window:** Excel allows you to open **multiple windows** for a single workbook at the same time to compare and view the different sections of the workbook. In our example, we’ll use this feature to compare two different worksheets **Spring** and **Summer** from the same workbook. Follow instructions below.

• Click the **View** tab on the **Ribbon**, then select the **New Window** command. A new window for the the workbook will appear. Notice a number is assigned to the name of the workbook as ExcelPart5.xlsx1 - Excel and ExcelPart5.xlsx2 - Excel in the **Title** area of the workbook.

• Regardless of which workbook number you are on, click on the **Arrange All** command. **Arrange Windows** dialog box will appear.

• Select **Vertical** to compare two different worksheets side by side in **Vertical** position. You can now compare different worksheets from the same workbook across windows. In our example, we’ll select **Spring** worksheet in one window and **Summer** in another to compare by using worksheet scrollbar on bottom left.
When you are done comparing, close either one. The number assignment at the end of the Title will disappear. Note: you can use New Window command to simultaneously open as many worksheets you want to compare at the same time.

**Splitting a Worksheet:** If you want to compare different sections of the same workbook without creating a new window, use Split command. The Split command allows you to divide the worksheet into multiple panes that scroll separately.

- In the same workbook, we will select Cell A18.
- Then click on the Split command under the View tab.
- The workbook will be split into different panes. Notice you can scroll each pane separately by using the scroll bars to view and compare different sections of the workbook.

When you are done, click on the Split command again to unsplit.

**Sorting**

When your data has increased in size, you may want to organize more systematically for easy retrieval. Use Sort function to organize a list of information alphabetically, numerically, and in many other ways. When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just a cell range.

**Sort Sheet by One Column:** Organizes all of the data in your worksheet by one column. Related information across each row is kept together when the sort is applied. Let’s use the same worksheet Spring to practice. In the example below, we want to sort by the name of the Employees (column A) has been sorted to display the names in alphabetical order. Follow the steps.

- Click on any cell in the Employee column.
- Click on either AZ for Ascending or ZA for Descending order.
- The entire worksheet will be sorted by the Employee column.
Sort Sheet by One or More Columns: You can use this command when you have more than one column to sort your data.

1. Click the sort command shown on right.
2. The Sort dialog box will appear.

3. Under Column, in the Sort by box, select the column that you want to sort. Select Car Rental.
4. Under Sort On, select the type of sort. In our example, keep at values since we are sorting the number values.
5. Under Order, do one of the following:
   - For text values, select A to Z or Z to A.
   - For number values, select Smallest to Largest or Largest to Smallest. We will select Smallest to Largest for this example.
   - For date or time values, select Oldest to Newest or Newest to Oldest.
6. Check the My data has headers box to indicate if you have a Header row (labels at the top row of the columns like in this example) or No header row (if none). Normally, Excel can sense the column headings and the selection box is already marked if number values are detected in one of the column.
7. To add another column to sort by, click Add Level (up to 64 levels) and then repeat steps 3 through 5 as necessary. To delete a level, click Delete Level.

Note: If you are sorting rows, then click Options and change the Orientation to Sort left to right. Just remember to change it back when you resume sorting columns.

Sort a Specific Cell Range: If your worksheet has different sets of data and you only want to sort a certain part of the worksheet, select that range of data only before you apply sort either by one column or by multiple columns as explained above. By selecting a specific range of cells, the other content in the worksheet was not affected by the sort.
Sort by Cell Formatting: One useful feature in Sort command is that you can sort your data based on the Cell Color. This feature can be found under the Sort On drop-down list in the Sort dialog box. This feature is especially useful if you format your cell to show with a particular color by using the Cell Formatting function then want to sort out those cells in color.

Assume we have a workbook tracking on payments for different regions by Sales Reps. Your conditionally formatted worksheet shows Full Payment in Green, Billed in Yellow, and Overdue in Red colors already. Open the worksheet SortbyColor in the same workbook to practice.

You want to sort those lines with Overdue on top then Billed followed by Full in Payment column. Follow these steps:

- Click anywhere within the data on the sheet.
- Click on Advanced Sort function under the Data tab.
- Select Payment for Column box; Cell Color for Sort On box; and Select the Red color first to show Overdue and select On Top in next box.
- Click on Add Level button to repeat the process above to add the Yellow color and Green color to be sorted in that order.
- Click on OK.
• Your data should be sorted by Overdue rows followed by the Billed and Full in Payment column as below.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>OrderDate</td>
<td>Region</td>
<td>Rep</td>
<td>Item</td>
<td>Units</td>
<td>Unit Cost</td>
<td>Total</td>
</tr>
<tr>
<td>2</td>
<td>5/6/13</td>
<td>Central</td>
<td>Jardine</td>
<td>Pencil</td>
<td>90</td>
<td>4.99</td>
<td>449.10</td>
</tr>
<tr>
<td>3</td>
<td>6/25/13</td>
<td>Central</td>
<td>Morgan</td>
<td>Pencil</td>
<td>90</td>
<td>4.99</td>
<td>449.10</td>
</tr>
<tr>
<td>4</td>
<td>9/11/13</td>
<td>Central</td>
<td>Smith</td>
<td>Desk</td>
<td>2</td>
<td>125.00</td>
<td>250.00</td>
</tr>
<tr>
<td>5</td>
<td>10/5/13</td>
<td>Central</td>
<td>Morgan</td>
<td>Binder</td>
<td>28</td>
<td>8.99</td>
<td>251.72</td>
</tr>
<tr>
<td>6</td>
<td>3/7/14</td>
<td>West</td>
<td>Sorvino</td>
<td>Binder</td>
<td>7</td>
<td>19.99</td>
<td>139.93</td>
</tr>
<tr>
<td>7</td>
<td>4/10/14</td>
<td>Central</td>
<td>Andrews</td>
<td>Pencil</td>
<td>66</td>
<td>1.99</td>
<td>131.34</td>
</tr>
<tr>
<td>8</td>
<td>6/17/14</td>
<td>Central</td>
<td>Kivell</td>
<td>Desk</td>
<td>5</td>
<td>125.00</td>
<td>625.00</td>
</tr>
<tr>
<td>9</td>
<td>7/21/14</td>
<td>Central</td>
<td>Morgan</td>
<td>Pen Set</td>
<td>55</td>
<td>12.49</td>
<td>666.95</td>
</tr>
<tr>
<td>10</td>
<td>11/17/14</td>
<td>Central</td>
<td>Jardine</td>
<td>Binder</td>
<td>11</td>
<td>4.99</td>
<td>54.89</td>
</tr>
<tr>
<td>11</td>
<td>12/21/14</td>
<td>Central</td>
<td>Andrews</td>
<td>Binder</td>
<td>28</td>
<td>4.99</td>
<td>139.72</td>
</tr>
<tr>
<td>12</td>
<td>4/1/13</td>
<td>East</td>
<td>Jones</td>
<td>Binder</td>
<td>60</td>
<td>4.99</td>
<td>299.40</td>
</tr>
<tr>
<td>13</td>
<td>6/8/13</td>
<td>East</td>
<td>Jones</td>
<td>Binder</td>
<td>60</td>
<td>8.99</td>
<td>539.40</td>
</tr>
<tr>
<td>14</td>
<td>10/22/13</td>
<td>East</td>
<td>Jones</td>
<td>Pen</td>
<td>64</td>
<td>8.99</td>
<td>575.36</td>
</tr>
<tr>
<td>16</td>
<td>4/7/14</td>
<td>East</td>
<td>Howard</td>
<td>Pen</td>
<td>96</td>
<td>4.99</td>
<td>479.04</td>
</tr>
<tr>
<td>17</td>
<td>5/31/14</td>
<td>Central</td>
<td>Gill</td>
<td>Binder</td>
<td>80</td>
<td>8.99</td>
<td>719.20</td>
</tr>
<tr>
<td>18</td>
<td>12/4/14</td>
<td>Central</td>
<td>Jardine</td>
<td>Binder</td>
<td>94</td>
<td>19.99</td>
<td>1,879.06</td>
</tr>
<tr>
<td>19</td>
<td>1/6/13</td>
<td>East</td>
<td>Jones</td>
<td>Pencil</td>
<td>95</td>
<td>1.99</td>
<td>189.05</td>
</tr>
<tr>
<td>20</td>
<td>1/23/13</td>
<td>Central</td>
<td>Kivell</td>
<td>Binder</td>
<td>50</td>
<td>19.99</td>
<td>999.50</td>
</tr>
</tbody>
</table>

**Filtering Data:**

If you further want to filter out your data into a smaller list to view or print for a particular purpose, use **AutoFilter** function in Excel. In order for filtering to work correctly, your worksheet should include a header row, which is used to identify the name of each column such as in our example, Order Date, Item, Region, etc. Let’s say, in our example, we want to just view data for a region separately.

• Click anywhere within the data. Select the **Data** tab, then click the **Filter** command.
• A drop-down arrow will appear in the header cell for each column.
• Click the drop-down arrow for the column you wish to filter. In our example, we will filter column B to view only certain regions.
• The **Filter** menu will appear.
• Uncheck the box next to Select All to quickly deselect all data.
• Check the boxes next to the data you wish to filter, then click OK. In this example, we will check Central to view only that region.

The data will be filtered, temporarily hiding any content that doesn't match the criteria. In our example, only Central Region is visible.
Applying Multiple Filters:

You can apply multiple filters to help narrow down your results. In our example, we've already filtered our worksheet to show the Central Region only, and we'd like to narrow it down further to only show rows with Overdue in Payment column. In the same worksheet *SortbyColor* -

- Click the drop-down arrow for the column you wish to add filter. In this example, we will add a filter to column H to view information by Payment.
- The Filter menu will appear.
- Check or uncheck the boxes depending on the data you wish to filter, then click OK. In our example, we'll uncheck everything except for Overdue.
- The new filter will be applied. In our example, the worksheet is now filtered to show only Overdue from Central Region.

Clearing Filter: If you want to clear filters one at a time, click the drop-down arrow for the filter you wish to clear. Choose **Clear Filter From [COLUMN NAME]** from the Filter menu.

OR

To remove all filters from your worksheet, click the Filter command on the Data tab again. **Clear all filters for next topic.**
Tables:

Once you've entered information into a worksheet, you may want to format your data as a **table**. **Tables include filtering by default.** You can filter your data at any time using the drop-down arrows in the header cells as long as your data is arranged in columns with descriptive column headings. You can use Excel’s **predefined table styles** to organize your content and make your data easier to use. Let’s use the same worksheet *SortbyColor*.  **Make sure you clear all filters.**

- Click anywhere within the data on your worksheet.
- From the **Home** tab, click the **Format as Table** command in the **Styles** group. Select a **Table Style** from the menu by clicking on one. You can change your **Table Style** later by hovering the mouse to another style.

- **Format as Table** window will appear. Excel indicates the cells to be included in the table setting with surrounding marching ants and the box to confirm “**My table has headers**” is already checked.
- Click **OK**.

- Each column header now has a drop-down arrow indicating a filter for each column. If you have any missing column headings, Excel will just insert a general column# which you can overtype and replace later. Now the data in this table can be filtered and un-filtered as if you had used the **Filter** command in the first place.

**Adding Rows or Columns in Tables:** Excel allows you **two ways** to add rows or columns.

1. Begin typing new content **after the last row or column** in the table. The row or column will be included in the table automatically. If there is any formula in original table, it will be copied into the new cell automatically.

2. Click, hold, and drag the bottom-right corner **Sizing Handle** of the table to create additional rows or columns.
Modifying Styles in Tables: You can turn various options on or off under the Design tab to change the appearance of any table. There are six options: Header Row, Total Row, Banded Rows, First Column, Last Column, and Banded Columns. You can see this option when you select any cell in your table.

From the Design tab, check or uncheck the desired options in the Table Style Options group.

To Remove a Table: Sometimes you may not want to use the additional features included with tables, such as the Sort and Filter drop-down arrows. You can remove a table from the workbook while still preserving the table's formatting elements, like font and cell color. To do that:

- Select any cell in your table. The Design tab will appear.
- Click the Convert to Range command in the Tools group.
- A dialog box will appear. Click Yes.

Divide Spreadsheet Data into the Smallest Parts:
Information in a column can be divided into the smallest parts for each filtering. For example, if a column contains both last and first names together, you can split that column into two separate columns; one for the last names, and the other for the first. By doing so, you can filter your data more efficiently. Let’s use summer worksheet in the same workbook to practice. First, select the entire first row that has the Title “Travel Expense Log Sheet” and delete it. In your spreadsheet where in column A, both last and first names are entered. We want to separate column A into two columns: one for the last names and the other for the first.

- First, an empty column needs to be inserted between columns A and to make a space for the newly separated last name column. Select the entire column B and click on the Insert command under the Home tab in the Cells group. A new empty column will be inserted between Employee and Registration columns.
• Select the entire column A (the column you wish to divide into two). Click the Data tab and click on the Text to Columns in the Data Tools Group. Convert Text to Columns Wizard dialog box will appear.

- You are asked to choose between the Delimited or Fixed width option buttons—although Excel automatically will suggest something for you. To understand the choices, you must understand what is meant by a delimiter. A delimiter is simply a character that identifies (delimits) the end of one number or word and the beginning of another. The character can be a comma, space or a tab. Excel is smart enough to examine your data and suggest whether you have delimited or fixed-width data. If your data appear in neatly aligned columns, as shown in the section of image on the right, it will select the Fixed width option button. If the data do not appear in neatly aligned columns such as in our example where the width of each first and last names are not aligned or even, it will choose the Delimited option button. Click the Next button to go onto step 2.
• Check the space box as we have a space between the names; click on Next.
• Click Finish to finalize your process and confirm to replace the empty new column you just added above with the split data by clicking on OK.
• The names column now should split into two columns: last and first names. See below. You can rename the header rows appropriately if you desire.

Combine two or more columns by using a function
Suppose you like to put together two or more columns of data that you want to combine in a single column, such as the name and phone number of a person. To combine two or more columns, use the CONCATENATE function in a formula in a nearby cell (typically to the right of the last column of data that you want to combine), and then drag that formula down through the rows that contain the data. When you create your formula, you can add a space or comma to cleanly separate names and addresses in the new column by enclosing them in quotation marks (" "). See below image. In this example, The CONCATENATE function combines column A, a space character (enclosed in quotation marks, like this: " "), column B, another space character, and column C into a single column D.

Open CombineCols worksheet and try formula in D2. Combine columns A, B, C into a single column D. Alternatively, you can also use the “&” in place of comma “,” to get the same result as above.
Create and Fill New Custom Lists:

There are only four kinds of built-in custom list: the day of week and the month of year. That means you can enter any value from the lists and make Excel to fill in the rest by using the Auto Fill or Fill Handle function.

Built-in Custom List

Sun, Mon, Tue, Wed, Thu, Fri, Sat
Sunday, Monday, Tuesday, Wednesday, Friday, Saturday
Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
January, February, March, April, May, June, July, August, September, October, November, December

Open a new worksheet in the same workbook to practice this concept.

- In Cell A1, type in “June” as a month. Hit Enter to complete the data. Select Cell A1 again.
- Use Fill Handle in Cell A1 and drag it all the way to Cell A16. Notice how the remaining months got filled in and entries on months restart from January after December.

Sometimes you may use some specific contents for many times in Excel, but without using the custom list you may have to reenter it over and over again. To avoid that you can create a custom list of these contents in Excel, and then you can quickly use the custom list at any time in Excel without retyping the same contents again. Let’s say you want to create a custom list of names.

You can do it with following steps:

- Click File>Options
- In the Excel Options dialog box, click Advanced button at left bar, scroll to the General section and click the Edit Custom List button. See image on right.
Now you get into the Custom Lists dialog box. Select the NEW LIST item in the Custom lists: box. And two ways to create new list:

1. You can type the custom list of values in the List entries box manually, and click Add button to insert your list to the Custom lists box. Note: You need type the list of values separated by Enter button or comma. See below.

2. If the values exist in current workbook, you can click the button to select the cells and click Import button to import it to the Custom lists box.
• Click OK > OK to close the Excel Options dialog box. And your custom list has been created, so when you enter the first value of your list, and then drag the fill handle to the cell that you want to fill, your custom list values will be filled into the cells in order.

• You can fill the values vertically or horizontally. If you pull Fill Handle to the right and down directions, the data will be entered in an increasing order. Pulling Fill Handle to the left or up directions will do the opposite.

More examples of series that you can fill

When you fill a series, the selections are extended as shown in the following table. In this table, items that are separated by commas are contained in individual adjacent cells on the worksheet.

<table>
<thead>
<tr>
<th>Initial selection</th>
<th>Extended series</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 2, 3</td>
<td>4, 5, 6,...</td>
</tr>
<tr>
<td>9:00</td>
<td>10:00, 11:00, 12:00,...</td>
</tr>
<tr>
<td>Mon</td>
<td>Tue, Wed, Thu,...</td>
</tr>
<tr>
<td>Monday</td>
<td>Tuesday, Wednesday, Thursday,...</td>
</tr>
<tr>
<td>Jan</td>
<td>Feb, Mar, Apr,...</td>
</tr>
<tr>
<td>Jan, Apr</td>
<td>Jul, Oct, Jan,...</td>
</tr>
<tr>
<td>Jan-07, Apr-07</td>
<td>Jul-07, Oct-07, Jan-08,...</td>
</tr>
<tr>
<td>15-Jan, 15-Apr</td>
<td>15-Jul, 15-Oct,...</td>
</tr>
<tr>
<td>1-Jan, 1-Mar</td>
<td>1-May, 1-Jul, 1-Sep,...</td>
</tr>
<tr>
<td>Qtr3 (or Q3 or Quarter3)</td>
<td>Qtr4, Qtr1, Qtr2,...</td>
</tr>
<tr>
<td>text1, textA</td>
<td>text2, textA, text3, textA,...</td>
</tr>
<tr>
<td>1st Period</td>
<td>2nd Period, 3rd Period,...</td>
</tr>
<tr>
<td>Product 1</td>
<td>Product 2, Product 3,...</td>
</tr>
</tbody>
</table>
**Quick Auto Fill Option:** You can use the *Quick Auto Fill* button to change the data you just filled in. This is especially useful for filling in data where you want to select between days, weeks, weekdays only, etc. Let’s say you want to fill in *weekdays only* for a few rows of data after you fill in a date in a cell.

1. Enter a date (1/2/15) in cell A1.
2. Use *Fill Handle* to fill in with dates for the next 20 rows. Once you let go of *Fill Handle*, Excel will fill in automatic dates beginning with 1/3/15. However, what if you want to just fill in with weekdays not weekends?
3. Hover your mouse on the *Auto Fill Option* command and click on the drop-down arrow next to it. Clicking on the drop-down arrow should give you a choice to fill in weekdays only.
4. Select that radio button and now the filled in dates will only include weekdays.

**Fill Command:** This command exists under the *Home* tab in the *Editing* group. You may also use this command to fill a range of cells with data. This is especially useful to fill in series of date value with step values such as every 3 days, 7 days, etc. For example, you wanted to fill every Monday beginning with a date 1/5/2015 for the entire year of 2015. Let’s follow the step below.

- Select cell B1. Type in 1/5/15 in that cell. That is a Monday.
- Select the entire column B.
- Click on the *Fill command* and click on the drop-down arrow and select *Series*.
- In the *Series* dialog box, change the *Step value* to 7 to indicate we want on a weekly basis and type in the *Stop value* as 12/31/15 to indicate that we want to fill only up to the end of the year.
- Click on *OK*. Your dates will only includes Mondays for the entire year until it stops on the last Monday 12/28/15.
- Note: Even though you selected the entire column B to fill in the data, having the stop value will let you stop at the last value, in this case, at a particular date 12/31/15.