Formatting text and numbers

In Excel, you can apply specific formatting for text and numbers instead of displaying all cell content in exactly the same way. Use formatting to change the appearance of dates, times, decimals, percentages (%), currency ($), etc.

To apply number formatting:

We will use FormattingCellsExample worksheet from ExcelPart3.xlsx. We’ll change the number format for the cells to modify the way dates are displayed.

1. Select the entire Column D to modify.
2. Click the drop-down arrow next to the Number Format command on the Home tab. The Number Formatting drop-down menu will appear.
3. Select the desired formatting option. In our example, we will change the formatting to Long Date. The selected cells will change to the new formatting style.

In our example, the width of Column D is not wide enough to fit the style of the format as the Error values ###### appear in every cell in that column. Just simply adjust the width of the column D and now you should see the content of the cells in the new formatting style – Long Date.
Other Number Formatting:

**General**: It is the default format for any cell. When you enter a number into the cell, Excel will guess the number format that is most appropriate. If you enter "1-5", the cell will display the number as a Short Date, "1/5/Year" (year representing the current year in 4 digits such as 2014).

**Number**: Formats numbers with decimal places. If you enter "4" into the cell, the cell will display the number as "4.00". For our practice, select Cells G3 through G11, change the range into Number format to see the mileage figures to show in two decimal points.

**Currency**: Formats numbers as currency with a currency symbol. If you enter "4" into the cell, the cell will display the number as "$4.00". For our practice, select Cell G13 and change the format to Currency.

**Accounting**: Formats numbers as monetary values like the Currency format, but it also aligns currency symbols and decimal places within columns. This format makes it easier to read long lists of currency figures.

**Short Date**: Formats numbers as M/D/YYYY. August 8th, 2013 would be "8/8/2013".

**Long Date**: Formats numbers as Weekday, Month DD, YYYY. 7/28/14 will be “Monday, July 28, 2014”.

**Time**: Formats numbers as HH/MM/SS and notes AM or PM. For example, "10:25:00 AM". You must enter PM or else all time without AM or PM will default to AM.

**Percentage**: Formats numbers with decimal places and the percent sign. If you enter "0.75" into the cell, the cell will display the number as "75.00%".

**Fraction**: Formats numbers as fractions separated by the forward slash. For example, if you enter "1/4" into the cell formatted as Fraction, the cell will display the number as "1/4". If you enter "1/4" into a cell that is formatted as General, the cell will display the number as a date, "4-Jan". **Note**: Format the cells to show Fraction first before entering the data.

**Scientific**: Formats numbers in scientific notation. For example, if you enter more than 11 digit numbers such as "140000000000" into the cell, then the cell will display the number as "1.40E+11". **Note**: By default Excel will format the cell in scientific notation if it contains a large number. If you do not want Excel to format large numbers with scientific notation, use the Number format.

**Text**: Formats numbers as text, meaning that what you enter into the cell will appear exactly as it was entered. Text is left-aligned while numbers are right-aligned by default. **If a cell contains both text and numbers Excel defaults to left-aligned.**

**More Number Formats**: Clicking on this will open up the Format Cells dialogue box with the Number tab where you can find more specific style of each format style explained above.

Your finished spreadsheet should look like the one shown on next page. Save and close the workbook.
Menu Version on Formatting Cells:
You can perform all of the formatting examples we went through above by using Menu Version of those commands rather than shortcuts on the Ribbon we used. A few extra commands not available on the Ribbon could be found here. Regardless of from which group on the Home tab: Font, Alignment, or Number you launch a dialogue box, the Format Cells dialogue box will open. Once it opens, you can freely click on other tabs to get to a particular command. See below.
**Worksheets**

Every workbook should begin with at least one worksheet in it which by default named as Sheet1. A workbook can contain multiple worksheets. As you build your workbook, you may like to add, delete or rename your worksheets or re-arrange the worksheet locations.

**Exercise:** Open WorksheetPractice.xlsx to practice. [Example from gcflearnfree.org]

**Renaming Worksheets**

We will rename the worksheets to organize the worksheets by months.

1. Right-click the Sheet1 and select rename from the menu.
2. Type in *January*.
3. Click anywhere outside of the worksheet, or press **Enter** on your keyboard. The worksheet will be renamed.
4. Alternatively, you can double-click and rename a worksheet.

   Double-click on Sheet2. The name Sheet2 will be highlighted. Then type in *February*. Do the same for Sheet3 renaming as *March*.

**Adding and Deleting Worksheets**

Simply click on the plus sign “+” at the end of all worksheets to add a new worksheet.

You may also use **Insert** from the right-click menu to insert a new worksheet. Doing so will add a new worksheet in front of the sheet you right-clicked.

To delete a worksheet, right-click on the sheet to be deleted. Select **Delete** from the menu.

**Note:** You can change the default number of worksheets when creating new workbooks. Go to the Backstage view under **File>Options** and change the number of worksheets in section that says “When creating new workbooks”.

![Excel Options](image)
Copy a Worksheet:
You can duplicate the content of a worksheet by using “Copy” function in Excel.

1. Right-click the worksheet you want to copy, then select Move or Copy from the worksheet menu.
2. The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before sheet: field. In our example, we'll choose (move to end) to place the worksheet to the right of the existing worksheet.
3. Check the box next to Create a copy, then click OK. The worksheet will be added at the end of existing worksheets; given the same name with a new version number in parenthesis. You may rename the sheet as April.

4. If you desire to move or copy a worksheet to an entirely different workbook, click on the drop-down arrow next to the section To book: and select (new book) or select any other workbook shown in the box. Be sure to check the “Create a copy” box if you are copying the worksheet.
Move a Worksheet:
1. Select the worksheet you wish to move. The cursor will become a small worksheet icon Mouse change.
2. Hold and drag the mouse until a small black arrow Mouse change appears above the desired location.
3. Release the mouse. The worksheet will be moved.

Change the worksheet color:
You can change a worksheet’s color to help organize your worksheets.

1. Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will appear.
2. Select the desired color. A live preview of the new worksheet color will appear as you hover the mouse over different options. In our example, we’ll choose Green.
3. The worksheet color will be changed. Note: The worksheet color is less noticeable when the worksheet is selected. However, once you select another worksheet, the color will appear more distinctively. See below.
Grouping and ungrouping worksheets:
When you work with multiple worksheets at the same time, worksheets can be combined together into a group. Any changes made to one worksheet in a group will be made to every worksheet in the group.

Exercise: Let’s use the same workbook WorksheetPractice.xlsx and practice the following steps.

**Grouping non-adjacent worksheets:**
- Select the first worksheet January
- Hold down the Control button on your keyboard and select the last worksheet April; let go off your Control button
- Now the January and April worksheets are selected, anything you change on January sheet will appear on the April sheet.
- Click Cell A1 and use Cell color fill to change to green color in that cell. Now Cell A1 should have the same color on both January and April worksheets.
- To ungroup those two sheets, you can either right-click on one of those two sheets and select Ungroup Sheets or just click on another sheet that was not in the original group.

**Grouping adjacent worksheets:**
- Select the first worksheet January
- Hold down the Shift button and select the last worksheet April and let go off your shift button
- Now all the sheets are selected anything you change on one sheet will appear on all other selected sheets
- Select Cells A2:D2 (A2 through D2) and change the text color to Red.
- All the cell blocks A2:D2 on all sheets will now have text with font color red.
- Click on any sheets that was not chosen first to group or use Ungroup Sheets command from the menu by right-clicking on any sheet.
Setting Up a Workbook:

You can set up the workbooks a certain way before you print out by using the Page Layout tab or by using the Page Layout View at the bottom right corner. The commands on the tab will let you change page orientation, paper size and margin size. You may also insert page breaks and repeat certain header row(s) to make your workbook easier to read. You can also launch the Page Setup dialog box and find more commands for the tab.

It is easier to use the Page Layout View at the bottom right corner to insert the Headers and the Footers visually.

Setting Page Orientation:
Excel offers two page orientation options: landscape and portrait. Landscape orients the page horizontally, while Portrait orients the page vertically. Portrait is especially helpful for worksheets with a lot of rows, while Landscape is best for worksheets with a lot of columns.

Exercise: Use the worksheet - Source Data from ExcelPart3.xlsx to practice.

- Change the view to see the worksheet in the Page Layout View at the bottom right corner.
- Use the Orientation on the Page Layout tab to view in Landscape. Change it back to the Portrait view and see which looks better for this example.
- Since we have more rows than columns in the worksheet, Portrait view is better for our example.
Setting Page Margins:

A margin is the distances from the edge of the page to the content on your page. By default, every workbook's margins are set to Normal, which is a one-inch space between the content and each edge of the page. Sometimes you may need to adjust the margins to make your data fit more comfortably on the page. Excel includes a variety of predefined margin sizes.

Exercise: Use the same worksheet - Source Data to practice.

- Click on the Page Layout view button on the bottom right corner. Then click on the Page Layout tab on the Ribbon and select the Margins command.
- Select the desired margin size from the drop-down menu. Select the Wide margin for our example to see how it looks to have a wider margin for the workbook.
- You may also select the Custom Margins command. Page Setup dialog box will be activated. Change the numbers of the Left, Right, Top, and Bottom to customize your margin width.
- You may also change the numbers under Header and Footer boxes to specify how much space do you want to keep between the edge of the paper and either a header or a footer.
- You can also specify how much you want to see your data centered on your worksheet printout. This is especially useful if you do not have much data.
• **Setting Print Area:**

Use the same workbook to practice this function. This command is especially useful if you want to print the subset of your huge data.

- Keep the worksheet in the **Layout** view.
- Select Cells A1:E12 to set as the Print Area.
- Click on the arrow on **Print Area** command and select **Set Print Area**.

No matter how large your data is, you are just setting to print that selection only.

- Click on **Print Area** one more time and select **Clear Print Area** to clear the chosen print area.

**Inserting or Removing Page Breaks**

You can add a break where you want the next page to begin in the printed copy. *Your page break will be inserted above and to the left of your selection.*

- Keep the worksheet in the **normal** view. We want to start a new page beginning row 17.
- Click on Cell A17 or select the entire row 17. (It is important you select the entire row or click the cell in the first column of the row to insert a page break.)

- Click on **Insert Page Break**. Click it away from row 17 and you should see the page break line above row 17.
- **Remove Page Break** – you need to select a cell right below the page break line to use this. In this example, entire row 17 or any cells on row 17.
- **Reset All Page Breaks** – your cell selection can be anywhere on your worksheet. By clicking this will reset all page breaks you put on your worksheet regardless of your selection.

- You can also view your worksheet in the **Page Break Preview** (by clicking on the last button at the bottom right corner). You shall see the page with *solid* dark blue lines as the page breaks. In this view, you can also move the breaks by pointing onto the lines and drag the mouse to the new location – up/down or left/right. Default page breaks lines are represented by the *dotted* dark blue lines and the manually created one has *solid* dark blue lines just like the boundary lines.
Printing Titles or Repeating Rows at the Top:
If your worksheet uses title headings, it’s important to include these headings on each page of your printed worksheet. It would be difficult to read a printed workbook if the title headings appeared only on the first page. The Print Titles command allows you to select specific rows and columns to appear on each page.

Exercise: Use the same worksheet - Source Data.

- Click on Print Titles command from the Page Setup tab. Page Setup dialog box will come up.
- Click on the red arrow for the box says – Rows to repeat at the top as shown below. (Note: you can also use the function Columns to repeat at left if you need the print out with repeated column(s) on every page.)

The Page Setup dialog box will be resized to a smaller size as shown in the picture below.

- To repeat the first row in our example where column headings are, click on Row Number 1 as if you are selecting the entire Row 1. The row selection will show as dotted moving lines. And the selection of the Row 1 will appear in the box as $1:$1 to indicate that we are selecting to repeat Row 1 on the top of every printed page.

- Click on the red arrow and the Page Setup box should open again.
- Click on Print Preview button to see that the header row is repeated on every page of the print out.
- Gridlines: Cell gridlines you see on screen will not print out unless you check out the Gridlines box in Page Setup box. This can be used alternative to setting Borders in cell.
- Row and column headings: If you desire to include the column names such as A, B, C and the row numbers 1, 2, 3 in your printout, check this box.
**Inserting Headers and Footers:**

The **header** is a section of the workbook that appears in the **top margin**, while the **footer** appears in the **bottom margin**. Headers and footers generally contain information such as page number, date, and workbook name that you want to repeat on every page. It is easier to insert headers and footers while in the **Page Layout view**.

**Exercise:** Use the same workbook above.

- Click on the **Page Layout** view on bottom right corner.
- Click in one of the three sections (left, middle, or right) appear in the header section of our worksheet. You should see **Header & Footer Tools** tab will appear on the **Ribbon**. Click on the **Design** tab.

- From here, you can access commands that will automatically include page numbers, dates, and workbook names in any of the three sections.
- Click on the **Current Date** command in the left section.
- Click in the middle section and type in your name.
- Click in the right section and then click on the **Page Number** command on the ribbon.
- You can click in the bottom part of the page to switch to the **Footer Section** and insert these commands or enter anything.
Printing

- To access the print pane, click on File menu on top. Click on print command.
- Print Preview will be shown as below.

1. **Printer**: If your computer is connected to multiple printers, click on the drop-down and select the printer.
2. **Print Active Sheets**: If your workbook has more than one worksheets and you want to print multiple worksheets, activate the worksheets first before you get to this Print Preview pane and select Print Active Sheets. Or select Print Entire Workbook OR choose Print Selection if you just highlighted a block of data to print.
3. **Pages**: You can specify particular pages to print by selecting page numbers in these two boxes.
4. **Collated**: If you are printing multiple copies, you can choose whether you want the copies collated or uncollated.
5. **Portrait Orientation**: Choose Portrait or Landscape.
6. **Letter:** If your printer uses different paper sizes, you can select your paper size here.

7. **Custom Margins:** Here you can adjust the page margins to fit the data better.

8. **No Scaling:** Scaling helps you to make small adjustments from the Print pane to fit your workbook content neatly onto a printed page. **Note:** Worksheets will become more difficult to read as they are scaled down, so you may not want to use this option when printing a worksheet with a lot of information.

9. **Flipping through pages:** Use right and left arrows to print preview your workbook with multiple pages to print.

10. **Show Margins:** Use this to view and adjust margins visually in print preview pane. The page margins will appear in the Preview pane. (See picture on right) Hover the mouse over one of the margin markers until the cursor becomes a double arrow. In our example, we’ll extend the left margin to place the spreadsheet more towards the center of the page.

11. **Copies:** Verify the number of copies you wish to print here.

12. **Print:** If you’re satisfied with all the adjustments you have made, click on Print to print your worksheet(s) or workbook.