**Find and Replace**

This feature helps you save time to locate specific information when working with a lot of data in Excel. You can easily search your workbook using the Find feature, which allows you to find the data and also modify content using the Replace feature.

**Exercise to find content:**

- From workbook `ExcelPart2.xlsx`, select `FlashFillExample` worksheet.
- From the Home tab, click the **Find and Select** command, then select **Find...** from the drop-down menu. *(Note: You can also access the Find command by pressing Ctrl+F on your keyboard.)*
- The Find and Replace dialog box will appear. Enter the content you wish to find. In our example, type in an employee’s last name “knight”.
- Click **Find Next** to find further instances or **Find All** to see every instance of the search term.
- When you are finished, click **Close** to exit the Find and Replace dialog box.
Exercise to replace content:

- In the same workbook, from the Home tab, click the Find and Select command, then select Replace... from the drop-down menu. (Note: You can also access the Replace command by pressing Ctrl+H on your keyboard.)
- The Find and Replace dialog box will appear.
- Type the text you wish to find in the Find what: field. Type “com”.
- Type the text you wish to replace it with in the Replace with: field. Type “net” then click Find Next.
- If the content is found, the cell containing that content will be selected.
- Review the text to make sure you want to replace it.

A dialog box will appear, confirming the number of replacements made. Click OK to continue.

- The selected cell content will be replaced. When you are finished, click Close to exit the Find and Replace dialog box.
Modifying Columns, Rows and Cells:

Inserting New Rows or Columns: You can insert a column/row or more than one column/row at any given time. If you select more than one column/row, the same numbers of columns/rows will be inserted. Exercise: From workbook ExcelPart2.xlsx, select CellBasics worksheet.

Columns: Select the column heading to the right of where you want the new column to appear. The following example shows inserting a new column before Column A. (For example, if you want to insert a column between columns D and E, select column E.) Then, click on Insert function in the Cells Group under the Home tab.

1. Insert a new column before column A.
2. Enter the new header “Customer” in Cell A1.

Rows: Inserting a new row or rows should work similarly. Select an entire row or a group of rows first; click on Insert function in the Cells Group under the Home tab. A new row or rows should be inserted above the selected row(s).

Resizing Rows & Columns: There are 3 ways to do this.

1) To resize a row or a column:
   - Select the entire Column A or any cell in the Column A. Change the Column width by using Home>Format>Column Width functions under the Home Tab. Type in the width “15”.
   - Click OK or press Enter.

2) Place the mouse between the row numbers or column letters. (The white cross will become a black line with arrows pointing up and down or sideways). Drag your mouse to the right or left to resize the column width, up or down to resize the row height.
   - Use the mouse function to resize this column A to width: 10. See below.

Place your mouse between the row numbers or column letters. When the symbol is present, double-click and Excel will resize the row or column for you.

   - Resize Column A to make it narrow enough to fit the contents just right. (Hint: Use double-click between Column A and B headings.)
**Note:** Rather than resizing rows and columns individually, you can modify the height and width of every row and column at the same time. This method allows you to set a uniform size for every row and column in your worksheet. To do this:

- Locate and click the **Select All** button; just below the **formula bar** to select every cell in the worksheet.
- Position the mouse over a **row line** or **column line** so the **white cross** becomes a **double arrow**.
- Click, hold, and drag the mouse to **increase** or **decrease** the row height or column width.
- Release the mouse when you are satisfied with the **new row height** or **column width** for the worksheet. See example below.

### Fit the Data Without Resizing Column:

You can fit the data in a cell without resizing the width of a column by using the **Wrap Text** command in the **Alignment Group** under the **Home Tab**. Use this command before or after entering data and the cell height will be automatically adjusted to **accommodate the current cell width**.

**OR**

You can use the keystroke combination **Alt + Enter** when you reach the end of the cell and you want to force the cursor to create another line within the same cell. **Note:** Click the Wrap Text command again to unwrap the text.

3. Enter the data shown in Cells A2:A5. See right. Do not worry about content not fitting in the column yet. Use either the down-arrow key on your keyboard or **Enter** key to move your selected cell to the cell below. The full content of Cell A5 is “Akron-Summit County Public Library”.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Customer</td>
<td>Order Date</td>
<td>Order Amount</td>
<td>Percentage</td>
</tr>
<tr>
<td>2</td>
<td>New Age Inc.</td>
<td>7/10/2014</td>
<td>1863.40</td>
<td>0.95</td>
</tr>
<tr>
<td>3</td>
<td>ABC Plumbing</td>
<td>7/17/2014</td>
<td>1552.60</td>
<td>0.78</td>
</tr>
<tr>
<td>4</td>
<td>Akron Art Museum</td>
<td>7/24/2014</td>
<td>654.06</td>
<td>0.33</td>
</tr>
<tr>
<td>5</td>
<td>Akron-Summit Council</td>
<td>7/31/2014</td>
<td>440.00</td>
<td>0.22</td>
</tr>
</tbody>
</table>
4. Select the entire column A. Click on the Wrap Text command in the Alignment group.

5. Select the entire Row 3. Use the Delete Command in the Cells Group to delete the entire row 3 and the row below with Akron Art Museum data will shift one row up to take the deleted row.

6. Let’s make all the columns width 15. Select the entire worksheet. Resize the column width to 15 by using Home>Format>Column Width. Still have the entire worksheet selected.

7. Let’s make Excel fit all contents in each column just right (not too wide or narrow). Double-click between any two columns to let Excel do the work for you.

8. Finally, click in any cell to de-select the entire worksheet.

9. Leave the workbook open.

Moving Columns or Rows:
If you want to move your entire row(s) or column(s) to re-arrange your data on your worksheet, you can do so. Exercise: We will move a column, but you can move a row in the same way. Use Source Data worksheet from ExcelPart2.xlsx workbook.

- Select the desired column heading (entire column A) for the column you wish to move, then click the Cut command on the Home tab OR by selecting from a right-click menu OR press Ctrl+X on your keyboard.

- Select the column heading to the right of where you want to move the column. For example, if you want to move a column between columns B and C, select column C. The following example shows to move column A between columns B and C.

- Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu.

- The column will be moved to the selected location, and the columns to the right will shift right. See right as Country column heading now appears before Order Date column heading.
To hide and unhide a row or column:

At times, you may want to compare certain rows or columns without changing the organization of your worksheet. Excel allows you to hide rows and columns as needed.

Exercise: Use the same worksheet opened above. In our exercise, we’ll hide columns C and D to make it easier to compare columns A, B, and E.

- Select the column(s) you wish to hide (Columns C and D), right-click the mouse, then select Hide from the formatting menu. The columns will be hidden. The green column line indicates the location of the hidden columns.
To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the columns on both sides of the hidden columns). In our example, we'll select columns B and E. Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear.

To merge cells using the Merge & Center command:
Cells can be merged in order to create larger cell areas – to create a title cell for the entire table, for example.

Exercise:
- Use the same worksheet already opened above.
- Insert a new row above the heading row 1. (Hint: Select the entire row 1 and select Insert from the Cells group under the Home tab.)
- Select the cell range you want to merge together. (Cells A1:E1)
- Select the Merge & Center command on the Home tab.
The selected cells will be **merged**, and the text will be **centered**. Save the workbook and keep it open.

Other Merge Options:

- **Merge & Center**: Merges the selected cells into **one cell** and **centers** the text.
- **Merge Across**: Merges the selected cells into **larger cells** while keeping each **row** separate.
- **Merge Cells**: Merges the selected cells into one cell, but **does not center** the text.
- **Unmerge Cells**: Unmerges selected cells.

**Formatting Cells**

Use Excel Formatting commands to draw attention to specific sections of your workbook and make your text easier to view and understand. You may also apply number formatting to tell Excel exactly what type of data you’re using in the workbook, such as percentages (%), currency ($), and so on. You can find all formatting commands under the **Home tab**: Font Group, Alignment Group, Number Group, and Styles Group.

**Exercise**: Use FormattingCellsExample worksheet from same workbook and follow instructions.

To change the font:

Excel provides a variety of other fonts you can use to customize your cell text though the default font is Calibri. In the example below, we’ll format our **title cell** to help distinguish it from the rest of the worksheet.

1. Select the **cell(s)** you wish to modify. Select the merged cells D1 through G1 for our practice.
2. Click the drop-down arrow next to the **Font command** on the **Home tab**. The Font drop-down menu will appear.

3. Select the desired font. A live preview of the new font will appear as you hover the mouse over different options. In our example, we'll choose **Elephant**. The text will change to the selected font.

To change the font size:

1. Select the same merged title cell you selected above.

2. Click the drop-down arrow next to the **Font Size command** on the **Home tab**. The Font Size drop-down menu will appear.

3. Select the desired font size. A live preview of the new font size will appear as you hover the mouse over different options. In our example, we will choose 14 to make the text larger.

   **Note:** You can also use *Increase or Decrease font size command* by click on either command.

To change the font color:

1. Select the same merged title cell you selected above.

2. Click the drop-down arrow next to the **Font Color command** on the **Home tab**. The **Color menu** will appear.

3. Select the desired **font** color. A live preview of the new font color will appear as you hover the mouse over different options. In our example, we'll choose **Purple**.

4. The text will change to the selected font color.
**Note:** You can also select **More Colors** at the bottom of the menu to access additional color options.

To use the **Bold**, **Italic**, and **Underline** commands:

1. Select the same merged title cell you selected above.

2. Click the **Bold (B)**, **Italic (I)**, or **Underline (U)** command on the **Home** tab. In our example, we'll make the selected cells **bold** to look like below.

   ![Bold, Italic, Underline Example](image)

   **Note:** You can also press Ctrl+B on your keyboard to make selected text **bold**, Ctrl+I to apply **italics**, and Ctrl+U to apply an **underline**. These commands are **Toggle Buttons** which means click to turn them on and click it again to turn them off.

**Text alignment**

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any numbers will be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows you to choose how the content is displayed in any cell, which can make your cell content easier to read.

![Alignment Buttons](image)

1. Select the same merged title cell you selected above.
2. Practice alignment by using the **Horizontal Center Alignment** button to make the title horizontally centered.
3. Next, use the **Vertical Center Alignment** button to make the title vertically centered.

![Alignment Example](image)

**Other Alignment Options:**

**Orientation:** You can rotate your text diagonally or vertically to label narrow columns by using this function.

**Exercise:** Continue using the same worksheet opened above.

1. Expand the height of the Row 2 up to about 90 pixels as shown.

![Height Example](image)

2. Select Cells D2 through G2.
3. Click the drop-down arrow from the **Orientation** button under the **Home tab** and select any of the orientation style to test. If you do not like the result, click on the same style to turn it off and the text should go back to horizontal style.

**Indentation:** Use this function to move the content further away or closer to the Cell border.

Select a few cells under the **Starting** or **Ending** header columns. Use either decrease or increase indentation buttons to test.
**Cell borders and fill colors**

*Cell borders* and *fill colors* allow you to create clear and defined boundaries for different sections of your worksheet. In our examples below, we'll add cell borders and fill color to our merged *title cell* to help distinguish them from the rest of the worksheet.

**To add a border:**

1. Select the same merged title cell you selected above.
2. Click the drop-down arrow next to the *Borders* command on the *Home tab*. The Borders drop-down menu will appear.
3. Select the border style you want to use. In our example, we will choose to display *Thick Box Border*.
4. The selected border style will appear.

**Note:** You can draw borders and change the line style and color of borders with the *Draw Borders* tools at the bottom of the Borders drop-down menu. Once you have selected your desired color and style of your border, your mouse will turn into a drawing pencil mode. You can point and click on multiple cells to draw a border or click on each cell border to draw border of each cell. **Turn off** the draw border function by clicking on *Borders* command on the *Home tab*.

**To add a fill color:**

1. Select the same merged title cell you selected above.
2. Click the drop-down arrow next to the *Fill Color* command on the *Home tab*. The Fill Color menu will appear.
3. Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse over different options. In our example, we'll choose Light Blue.
Cell styles

Rather than formatting cells manually, you can use Excel's **predesigned cell styles**. **Cell styles** are a quick way to include professional formatting for different parts of your workbook, such as **titles** and **headers**.

1. Select the cells with headers in them: Date, Starting, Ending, Miles.
2. Click the **Cell Styles command** on the **Home tab**, then choose the desired style from the drop-down menu. In our example, we'll choose **Accent 1**.
3. The selected cell style will appear.
4. Select Cells D3 through G13 and apply the **Note Cell Style**.

**Note:** Applying a cell style will replace any existing cell formatting **except** for text alignment. You may not want to use cell styles if you've already added a lot of formatting to your workbook.