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Microsoft Excel 2003: Part V 
Advanced Custom Tools  

Windows XP 
______________________________________________________________________ 
 
(I)  Linking Data from Several Worksheets and Workbooks 
 

In Excel Level III, we have learned and seen examples of how to link data from one 

worksheet to the next in the same workbook.  Here, we are going to expand those 

examples one step further by: 

 

1. Linking among several worksheets in the same workbook  

2. Linking data from one workbook to another 

 

1. Linking among several worksheets in the same workbook  
 

a) Open “PersonalBudget.xls” workbook on your computer.  In this workbook, 

there are four separate worksheets: Total Budget, Income-Expense Yearly 

Report, Daily-Living Expense, and Charts.  Total Budget is set up to input all 

possible income sources and expenses from January through December for any 

given year.  Income-Expense Yearly Report is set up just to pull out each 

category at the end of each month to see overall view of the budget sheet.  Total 

Budget and Income-Expense Yearly Report worksheets will be linked.  Daily-

Living Expense is set up as an example to feed data on a weekly basis.  You 

may set up for similar worksheets for other expense categories if needed.  



Charts worksheet is created to show a few examples to see your data visually.  

Again, you may create more charts on other expense categories.  

 

 
 

b) Let’s link the January figure cell B3 on Income-Expense Yearly Report 

worksheet with income totals cell B8 in Total Budget worksheet.  When all 

possible income in January is filled in the January column in Total Budget 

worksheet we want to see the result of total incomes shows up in cell B3 of 

Income-Expense Yearly Report automatically.  Type the ‘=' sign in cell “B3” on 

the Income-Expense Yearly Report sheet under January column.  Then click on 

cell B8 (your source data) in the Total Budget sheet to link.   

 

 
Income-Expense Yearly Report Worksheet 
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c) Click in cell “B8” and hit “Enter” while the cell is still surrounded by marching 

ants. (Note: You do not need to click anywhere else.) 
 

 
Total Budget Worksheet 

d)   You will be back at the Destination sheet (Income-Expense Yearly Report, in 

this example) to see the results.  Click on the cell where you placed the links – 

cell B3 in this example.  The formula bar shows the linking formula as 

‘=TotalBudget!B8’, meaning Cell B3 on the Income-Expense Yearly Report 

sheet is linked to cell B8 on the Total Budget sheet. 

 

 
 

e) You can copy the formula in cell B3 on the Income-Expense Yearly Report sheet 

to cell C3, D3, and E3, so on up to M3 for the remaining months.  Excel will 

relatively change the cell addresses to reflect appropriate columns from the 

Total Budget sheet.   
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(Note: Use Fill Handle to drag and copy formula 

from cell B3 to cells C3 through M3.) 

 

 

 

 

 

 
 
 
 
Go to Exercise 1 and try linking more cells from Total Budget worksheets to the 

Income-Expense Yearly Report sheet.  
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2.  Linking data from one workbook to another  
 

Assume that you like to see details on how much financial assistance you are 

providing to your child in each month.  You probably will create a separate 

workbook that contains detailed lines on the type of assistance you provide.  

Open FinancialAssistance.xls workbook.  At the end of each month you will 

incorporate the total figure for the month into your PersonalBudget.xls 

workbook.  Here is how.   

 

• Open the PersonalBudget.xls workbook.  (Destination workbook).  Click 

on the cell B103 in Total Budget worksheet where you want your linked 

data to appear for January figure on financial assistance.  Type the “=” 

sign in the cell. 

• Open the FinancialAssistance.xls workbook (Source workbook).  

• Click on the cell that contains the January total financial assistance figure 

– cell B9.  Hit “enter”.  You will see the result in your Destination 

workbook, PersonalBudget.xls right away.  Save your work after linking. 
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Next time you open the PersonalBudget.xls workbook, a message box shown below 

will come up to remind you that the workbook contains links to other data sources.  If 

those data sources were updated, you do want to include those updates in your 

workbook.  Click on “Update” to let Excel attempt to retrieve the latest data from your 

source workbooks.  See below. 

 

 
 

Go to Exercise 2.      
 

Note:  Make sure you click on “Update” when opening your PersonalBudget.xls to 

retrieve the latest data from your source workbooks. If you desire to use the previous 

information but not the updates, click on “Don’t Update”.   
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(II)  Create a Drop-down List from a range of cells 
 

To make data entry easier when you have more than one option to select, or to limit 

entries to certain items that you define, you can create a drop-down list of valid entries 

that is compiled from cells elsewhere on the worksheet.  When you create a drop-down 

list for a cell, it displays an arrow next to that cell.  To enter information in that cell, click 

the arrow, and then click the entry that you want. 

 

Here is how you create a Drop-down List. 

 

1. You need to create a list of valid entries for the drop-down list.  You can type the 

entries in a single column or row normally without blank cells.  You can open up 

a separate worksheet in the same workbook and type in your entries on that 

worksheet.  (Normally, you want to place all your lists on one worksheet in 

separate columns.) 

 

2. Sort the data in the order that you want it to appear in the drop-down list. 

 

3. Define a name for the list.  Here is how. 

 

a. Select the cells or range of cells that you want to name.  

b. Click on Name box at the left end of the formula bar.   

c. Type the name of the cells and hit ‘Enter’.  OR   

 

OR 

 

a. Select the cells or range of cells that you want to name. 

b.  Click Insert>Name>Define. 

c. Type in a name, click OK. 

 



Assume you have to identify your department on your weekly timesheet, and there are 6 

departments in your company such as Sales, Finance, R&D, MIS, Accounting, and 

Marketing.   On a separate worksheet, type in the names of all departments and sort 

them out in ascending order.  You probably want to begin your list with a cell that reads 

‘Select One’ to indicate that there is a drop-down list in this cell.  See example below. 

 

 
 

4. Select a cell on the worksheet where you want to show the list.  Click on: 

 

a. Data on your Toolbar. 

b. Select Validation.  The Data Validation dialog box will appear. 

c. Select List from the drop-down choice in the Allow box. 

d. In the Source box, type in the ‘=’ equal sign and the name of the list.  
e. Make sure that the In-cell drop-down check box is selected. 

f. To specify whether the cell can be left blank, select or clear the Ignore blank 

check box.  Click OK.  See below. 
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Once a drop-down list is created for these departments, it should look like this in the 

result cell.  
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g. Optionally, you can display an input message when the cell is clicked.  Click 

on the Input Message tab in the Data Validation box and type in your Title 
and message in Input Message box.  Check the box that says “Show the 

input message when the cell is selected”.  Type in an appropriate title in the 

Title box and a message in the Input Message box.  Click OK.  See below for 

example. 

 

 
 

The following example displays an input message when the cell is clicked. 
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h. You may also “stop” user from inputting invalid data by using “Error Alert” 

function in this Data Validation window.  You will have to use in combination 

with “Settings” function.  Assume in this timesheet example, you want to limit 

user to input sick hours as whole numbers between 1 to 8 hours.  You can 

place your limits by following the steps below. 

 

First, select the cell or cell blocks you want to put your limits.  In this example, 

block cell E4 through E10.  Next, click on Data>Validation; use “Settings” tab in 

Data Validation window to set sick hours limit between 1 to 8 hours in whole 

numbers by using drop-down arrows.  See below. 
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Next, click on “Error Alert” tab to input your “Error message” if invalid data is 

placed in those cells.  Under “Style”, using “Stop” will not let user to input any 

invalid data while “Warning” and “Information” will show the “Error message” but 

will let the user input invalid data.  Make sure “Show error alert after invalid data is 

entered” box is checked to show the “Error message”.  

 

 
 

If an invalid data is placed in those cells and if you use “Stop” under Style to stop 

the user for doing so, the following window will pop up and make the user to 

correct the data until it meets the criteria. 
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(III)  Sharing Your Workbook with Multiple Users 
 
First, you need to store your workbook at a network location where multiple users can 

log onto and use it.  Share your workbook by clicking on Tools>Share workbook and 

check the box to allow changes by user more than one user at the same time.  This 

means that more than one person can edit the same data, even simultaneously.   

 

 
 

To verify how many days to keep track of changes and how you would like to save the 

updates, click on the Advanced tab and make your choice.   
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After sharing your workbook, the word [shared] will appear next to your file name in the 

title bar. 

 
 

If each user uses their own computer assigned under their name, individual users can 

log onto their computer, retrieve the shared workbook from the network location 

(provided they have access to a network), and edit it. Individual changes can be traced 

by user name.  To see who else has the workbook open, click Share Workbook on the 

Tools menu, and then click on the Editing tab.  See below for example. 
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In a case where everyone shares one computer to edit the shared workbook, the person 

needs to identify their user name to validate their changes.  To do this, follow these 

steps. 

 

a) Open the workbook. 

b) Set the user name to identify your work in the shared workbook: on the Tools 
menu, click Options, click the General tab, and then type your user name in the 

User name box.  Click OK.  See below.  You need to identify yourself every time 

you open the workbook before you make changes. 

 

 
 

c) Enter and edit data as usual.  Then save your work.  To trace who made what 

changes, click on Track Changes under the Tools menu.  Select Highlight 
Changes, and check the box where it says List changes on a new sheet.  See 

box below. 
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The When box gives you a choice to see: all changes, since I last saved, not yet 

reviewed, or since date.  You can make your choice to see changes made by 

everyone, everyone but me, or individual user name by clicking on drop-down box 

next to Who: .    By checking the box to see the changes on a new sheet, you can 

see details of changes made by different users on a separate worksheet 

automatically named as History sheet in same workbook.  The list details the date, 

time, who, where and what changes were made by all users.   See below. 

 
Note: If you prefer seeing changes made in each cell by seeing comments upon selecting that cell, 

check the box for Highlight changes on screen. (Note: Either choice is fine. It’s your personal 

preference. It’s a bit easier on eye to see the list on a separate sheet. Save the history sheet by 
copying it into a new workbook to preserve it before you stop sharing your workbook or else 
all history on track changes will be gone.  The History sheet will not automatically save. )  
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(IV)  Protect a Shared Workbook 
 

Protecting a shared workbook will prevent against other users removing the shared 

workbook’s change tracking feature and require that a password be used to unprotect it.  

 

1. Open Tools, point at Protection, and click Protect Shared Workbook.  (If you 

have not already shared the workbook, you will see Protect And Share 
Workbook.  Password can be only added if the workbook is unshared at the 

time of Protection. ) 
2. In the Protect Shared Workbook dialog box, select Sharing With Track 

Changes. 
3. Either click OK or type a password (if workbook is unshared at the time of 

protection) and click OK. In the Confirm Password dialog box, type the 

password a second time and click OK.   
(Note:  If the workbook is already shared, when you point to Protection on the 

Tools menu, click Protect Shared Workbook, and select the Sharing with 
Track Changes check box, you cannot assign a password for this protection.  To 

assign this password, you must first unshare the workbook.) 
 
To stop sharing a workbook 

 
Do the followings: 

 

1. Have all other users save and close the shared workbook.  If other users are 

editing, they will lose any unsaved work. 

2. Unsharing the workbook will delete the change history.  If you want to keep a 

copy of this information, print out the history worksheet or copy it to another 

workbook and save it. 

3. On the Tools menu, click Share Workbook, and then click the Editing tab. 

4. Make sure that you are the only person listed in the Who has this workbook 
open now box. 
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5. Clear the Allow changes by more than one user at the same time check box.  

(Note:   if this check box is not available, you must have protected your 

workbook.  You must unprotect the workbook before clearing the check box.) 

6. When prompted about the effects on other users, click Yes. 

 

Note:  Sharing a Workspace is not the same as sharing a workbook.  Shared 

workspaces are areas on Microsoft Windows SharePoint Services web sites where 

people can access documents and other data.  You can create a workspace and copy a 

workbook to it from the Shared Workspace task pane. 

 



(V)  Protect Worksheet or Workbook Elements 

Protecting your workbook becomes essential once it is shared among multiple users so 

that someone cannot delete or change data in certain cells by accident. Nor can they 

insert/delete columns, among other things.  To prevent anyone from accidentally or 

deliberately changing, moving, or deleting important data, you can protect certain 

worksheet or workbook elements, with or without a password.  Excel passwords can be 

up to 255 letters, numbers, spaces, and symbols. You must type uppercase and 

lowercase letters correctly when you set and enter passwords.   

Guard Workbooks with Passwords 

It is simple but effective.  If you know the correct password, you can open and/or modify 

the file. With an Excel workbook open, open File and click Save As. 

In the Save As dialog box, select Tools on the toolbar, and click General Options.   

 

 

 

 

 

 

Follow the directions below to decide level of security for your workbook.   
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Your Options to select level of security 

In the Save Options dialog box, File Sharing area: 

1. Type a password in the Password to Open text box to control who 

can open the workbook. If you absolutely want no one to open your 
workbook without your permission (without password), use this 
option! 

 

2. Type a password in the Password to Modify text box to control who 

can modify contents.  Use this option and option #1 above 
combined when you desire to allow the user to open your 
workbook and make changes.  By adding another password at 
this level provides an extra layer of security level to allow those 
only who have passwords to open and modify data.   (Leaving this 

password blank allows user who has password to open to make 

changes without your permission; adding a password effectively 

provides read-only access to those who do not have the password to 

modify.) 

 



 

3. Select Read-only Recommended to prevent changes without 

requiring a password.  By checking this option combined with 
options #1 and #2 above will give those who have both 
passwords to view and modify to work with workbook freely.  For 
those users who only have password to view workbook as ‘read 
only’ will be given a notice box that says “enter password for 
write access, or open read only” as shown below.   

 

When user clicks on Read Only, the workbook opens with filename 

attached by [Read Only] in brackets at the end.  See below. 
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If those users with ‘read only’ access try to modify and save the 

document, Excel warns the user to save the workbook under a 

different name by using “save as” option.  See below.   

 

 

 

 

By clicking “OK” Excel will automatically create a new 

workbook with the name begins with “copy of…..” in Save As 

Dialog box.  See below. 

 

Removing a Password 

Only the originator of a file can remove its passwords and thereby turn off access 

controls. 

1. Open File and click Save As. 
2. In the Save As dialog box, select Tools on the toolbar, and click General 

Options.  In the Save Options dialog box, delete the password(s) in the text 

boxes whose controls you want to remove. 

3. Click OK and then click Save.  Click Yes to replace the existing file. 
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(VI)  Protect Worksheet Elements 
 
Worksheet protection applies only to the currently active worksheet.  To protect all 

elements that can be protected: 

 

1. Open Tools, point at Protection, and click Protect Sheet. 
2. Ensure that the Protect Worksheet and Contents of Locked Cells check box 

is selected.  Optionally, type a password to unprotect the worksheet. 
3. Deselect all check boxes in the Allow All Users of This Worksheet To list box, 

and click OK.  If necessary, confirm the password and click OK.   By doing so 
no one will be able to modify your worksheet. 
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If you desire to allow users to modify data in certain elements of your worksheet, 

you can selectively protect worksheet elements.  For example, if you want to allow 

other family members to input data in your Total Budget worksheet of the 

PersonalBudget.xls workbook but do not want them to modify any other part of the 

worksheet such as cells that contain formulas, for example, do the followings. 

 

1. Select the range of cells they can input data.  In this example, let’s try 

on income data cells - B5 through M7, where they will place values of 

income figure, are selected first. 

 

 

 

Open Format, point at Cells, and click Protection.  By default, Locked 

check box is always checked.  That means all cells are generally locked.  

You want to clear the Locked check box for those selected range of cells 

above so click OK below. 
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2. Open Tools, point at Protection, and click Protect Sheet. 
3. Ensure the Protect worksheet and contents of locked cells check 

box is selected.  Optionally, type a password to unprotect the 

worksheet. 

4. In the Allow users of this worksheet to list box, select the worksheet 

elements and actions you want the user to be able to perform.  In this 

example, assume you will only let other family members to input data 

into those blue ranged cells selected in step 1.  Make sure to clear all 

remaining boxes except select unlocked cells box.  See below.  Click 

OK.  If necessary, confirm the password and click OK.   
 

 
By protecting the worksheet like this, only those unlocked cells can 

be edited.   
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(VII)  Protect Workbooks 
  

This option is used to protect the structure of a workbook and to keep workbook 

windows in the same size and position each time the workbook is opened.  

 
1. Open, Tools, point at Protection, and click Protect Workbook. 

 
 
 
 
 
 
 

• Select Structure to prevent changes to non-content aspects of the 

workbook, which include viewing hidden worksheets; inserting, moving, 

deleting, renaming, or hiding worksheets; and moving and copying 

worksheets and more. 

•  Select Windows to prevent resizing and repositioning workbook windows. 

 

2. Optionally, enter a password.  Click OK.  If necessary, confirm the password 

and click OK again. 
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Exercises 
 

Exercise 1 
 Linking Data from Several Worksheets
 

1. Using the PersonalBudget.xls file, link Income-Expense Yearly Report 

worksheet to Total Budget worksheet for Home Expense for the month of 

January.  (Hint:  Find out what cell in your source data contains total 

expense figure for January.  Then start placing links from Income-Expense 

Yearly Report worksheet.)   

2. Copy your January Home Expense result in Income-Expense Yearly 

Report worksheet into February through December cells.    

3. For practice, link each expense category in Income-Expense Yearly 

Report worksheet to appropriate cell in Total Budget worksheet.   

Try placing actual Dollar figures in Total Budget and see the Income-

Expense Yearly Report worksheet updates instantly. 

4. For more practice, link each category under Daily Living Expense from 

Total Budget worksheet to appropriate cells in Daily Living Expense 

worksheet. 

 

Exercise 2 
Linking Data from one Workbook to another 
 
Link February financial assistance figure from FinancialAssistance.xls workbook 

to PersonalBudget.xls workbook. (Hint:  Open PersonalBudget.xls workbook, 

starting from selecting the cell C103 to incorporate total February financial 

assistance from FinancialAssistance.xls workbook. Type ‘=’ sign in that cell 

and continue the remaining steps.  You may also copy cell B103 to C103 and so 

on through the month of December.) 

 

http://www.akronlibrary.org/training/pdf/PersonalBudget.xls
http://www.akronlibrary.org/training/pdf/FinancialAssistance.xls
http://www.akronlibrary.org/training/pdf/PersonalBudget.xls
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Exercise 3 
Creating a Drop-Down List
 

Open Drop-Down List.xls workbook and activate List worksheet in the workbook.   

Select cell range E2:E14 and name that range of cells as ‘Holiday’.  Then click on 

Timesheet worksheet in the workbook and create a list for all those cells under 

Holiday Type column except for those cells that show Sub Total and Total 

figures.  (Hint: Select range of cells to attach list of holidays on each cell or you 

may select individual cells to do so.  Go to Data>Validation and select List from 

the Allow box. In Source box, type in ‘=’ equal sign and Holiday (The name of 
the range of cells that list all holidays on List worksheet.)  
 

Also create a warning if someone tries to enter an invalid value in any of these 

cells.  (Hint: In Data Validation box, under Settings tab, make sure to uncheck 

ignore blank box.  By doing so will prevent the user to input any value except 

from the list.  Click on Error Alert tab and put in appropriate warning and Error 
message.  Click Ok.)  Try to place any invalid value in those cells and see what 

happens. Note:  If you create wrong list or warning messages, click on “clear all” in Data 

Validation box under each tab. 

 

Exercise 4 
 

Protect Worksheet Elements 
 

Open PersonalBudget.xls and activate Total Budget worksheet.  Protect the 

worksheet except for those cells (B5:M7) range where income figures can be put 

in.  (Hint:  Select those cell ranges first, go to Format>Cells>Protection and 

uncheck the Locked box and continue the remaining steps to protect the entire 

worksheet. Remember locking or unlocking cells has no effect unless the 

worksheet is protected.) 

 

http://www.akronlibrary.org/training/pdf/Drop-Down%20List.xls
http://www.akronlibrary.org/training/pdf/PersonalBudget.xls

