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Microsoft Excel – Part 5 

Using Excel tables 
 

Once you've entered information into a worksheet, you may want to format your data as a table.  

Tables also include filtering by default. You can filter your data at any time using the drop-down arrows 

in the header cells as long as your data is arranged in columns with descriptive column headings.  You 

can use Excel’s predefined table styles to organize your content and make your data easier to use.  Let’s 

use the worksheet SortbyColor in the Advanced Excel Skills 1.xlsx  

 

 Click anywhere within the data on your worksheet. 

 From the Home tab, click the Format as Table command 

in the Styles group.   Select a Table Style from the menu 

by clicking on one. You can change your Table Style later 

by hovering the mouse to another style.. 

OR 

 You can use Insert>Table command. 

 
 

 

 Format as Table or Create Table window will 

appear.  Excel indicates the cells to be included in 

the table setting with surrounding marching ants 

and the box to confirm “My table has headers” is 

already checked.  

 Click OK. 

 

 Each column header now has a drop-down 

arrow indicating a filter for each column.  If you 

have any missing column headings, Excel will 

just insert a general column# which you can 

overtype and replace later.  Now the data in 
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this table can be filtered and un-filtered as if you had used the Filter command in the first 

place.   

 

When you create an Excel table, Excel assigns a name to the table.  In our case, Excel just assigned the 

generic name Table1.  Look under the Design tab in the Properties group under Table Name.  You may 

change the Table name as you like but your table name must not have spaces in between.  Creating a 

Table also provides names to each column in the table. When you add formulas to an Excel table, those 

names can appear automatically as you enter the formula and select the cell references in the table 

instead of manually entering them.  That means instead of using the explicit cell references such as 

=E2*F2, Excel will use =Units*Unit Cost if you enter the formula and select the cell references in the 

table instead of manually entering them.  Let’s practice, adding a Total column back into our data sheet.  

Select cell G1 and type the word “Total” and hit Enter.   

 

You can see Excel included the new column G into its Table reference. 

 

Now, enter a formula in cell G2 by selecting the cell references.   

 Type in = sign in G2. 

 Point and click cell E2 to include in your formula.  Excel enters the name of the column 

“Units” instead of the explicit cell reference E2.  

  

 Type in * sign to multiply. 

 Point and click cell F2 to include in your formula.  Again, Excel uses the name of the column 

“Unit Cost” in the formula.  

 

 Hit enter to complete your formula.  You will see that Excel automatically creates a 

calculated column and copies the formula down the entire column for you, adjusting it for 

each row. 
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That combination of table and column names is called a structured reference. The names in structured 

references adjust whenever you add or remove data from the table.  Structured references also appear 

when you create a formula outside of an Excel table that references table data. The references can make 

it easier to locate tables in a large workbook. 

 

Adding Rows or Columns in Tables:  Excel allows you two ways to add rows or columns. 

1. Begin typing new content after the last row or column in the table. The row or column will 

be included in the table automatically.  If there is any formula in original table, it will be 

copied into the new cell automatically. 

2. Click, hold, and drag the bottom-right corner Sizing Handle of 

the table to create additional rows or columns.  

 

 

 

Modifying Styles in Tables:  You can turn various 

options on or off under the Design tab to change the 

appearance of any table. There are six options: Header 

Row, Total Row, Banded Rows, First Column, Last 

Column, and Banded Columns.   You can see this option 

when you select any cell in your table.  

From the Design tab, check or uncheck the desired 

options in the Table Style Options group.   

 

To Remove a Table: Sometimes you may not want to use the additional features included with tables, 

such as the Sort and Filter drop-down arrows. You can remove a table from the workbook while still 

preserving the table's formatting elements, like font and cell color. To do 

that: 

 

 Select any cell in your table. The Design tab will appear. 

 Click the Convert to Range command in the Tools group.  

 A dialog box will appear. Click Yes. 
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Split Column OR Divide Spreadsheet Data into the Smallest Parts: 

Information in a column can be divided into the smallest parts for each filtering.  For example, if a 

column contains both last and first names together, you can split that column into two separate 

columns; one for the last names, and the other for the first.  By doing so, you can filter your data 

more efficiently.  Let’s use summer worksheet in the same workbook to practice.  First, select the 

entire first row that has the Title “Travel Expense Log Sheet” and delete it.  In your spreadsheet 

where in column A, both last and first names are entered.  We want to separate column A into two 

columns: one for the last names and the other for the first.   

 

 

 

 

 

 First, an empty column needs to be inserted between columns A and B to make a 

space for the newly separated last name column.   

 

 

 

 Select the entire column B and click on the Insert command under the Home tab in the Cells group.  

A new empty column will be inserted between Employee and Registration columns.  Select the 

entire column A (the column you wish to divide into two).  Click the Data tab and 

click on the Text to Columns in the Data Tools Group.   Convert Text to Columns 

Wizard dialog box will appear.  
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 You are asked to choose between the Delimited or Fixed width option 

buttons—although Excel automatically will suggest something for you. 

To understand the choices, you must understand what is meant by a 

delimiter. A delimiter is simply a character that identifies (delimits) the 

end of one number or word and the beginning of another. The character 

can be a comma, space or a tab. Excel is smart enough to examine your 

data and suggest whether you have delimited or fixed-width data.   If 

your data appears in neatly aligned columns, as shown in the section of 

image on the right , it will select the Fixed width option button.  If the 

data does not appear in neatly aligned columns such as in our example 

where the width of each first and last names are not aligned or even, it 

will choose the Delimited option button. Click the Next button to go 

onto step 2. 

 

 

 

 Check the space box as we have a 

space between the names; uncheck 

the Tab box; click on Next.  

 Click Finish to finalize your process 

and confirm to replace the empty 

new column you just added above 

with the split data by clicking on 

OK.The names column now should 

split into two columns: last and first 

names.  See below.  You can 

rename the header rows 

appropriately if you desire. 

 

 

 

 

 

 

Flash fill 
Splitting column can be easily done by using Control + E key combination. It is called Flash Fill function 

available in Excel 2013 and later.  Flash Fill automatically fills your data when it senses a pattern. For 

example, you can use Flash Fill to separate first and last names from a single column, or combine first 

and last names from two different columns.  
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Open the SplitColumns worksheet.  We want to pull out just last names and first names from the email 

addresses listed in Column A.  In Cell B2, type in the first name “Shawna”. Hit Enter.  You are in Cell B3 

now. Hold down Control button and hit E on keyboard. All first names on respective rows will appear.  

Select Cell C2 and type in “Buck” as last name; hit Enter to be in Cell C3. Hold down Control button and 

hit E on keyboard; all last names will show up in respective rows. 

Click on the Employees worksheet.  Type in first name and last names in separate cells in Cell B2 and C2; 

such as John in B2 and Close in C2. 

Now, select Cell B3 and do Control+E  or go to Data>Flashfill to enforce the flash fill.  The remaining rows 

should be completed with separate first names. Do the same in Cell C3. Select C3, then Control+E. You 

should see all last names filled in the remaining rows. 

 

CONCATENATE Formula in Excel 
Concatenate function is used to join two or more text strings into one string. Important: In Excel 2016, 

Excel Mobile, and Excel for the web, this function has been replaced with the CONCAT function. 

Select Cell D2 in Employees worksheet.  Combine the first names in column B and last names in column 

C into a single column by using 

=CONCATENATE(B2,” “,C2) 

 

Applying the quick analysis tool 
Quick Analysis takes a range of data and helps you pick the perfect chart with just a few commands. 

Select a range of cells. Select the Quick Analysis button that appears at the bottom right corner of the 

selected data. Or, press Ctrl + Q. 

 Use the Quick worksheet in the same workbook.  Highlight the header row and a few rows of data. You 

should have a Quick Analysis tool shows up at the bottom right of the selected data. Note: It's important 

to remember that this button only becomes active for a specific data selection and does not appear 

when highlighting blank cells, entire columns or rows. 

 

 

Point on it and you should see readily available tools for you to quickly analyze your data.  Place your 

mouse on each options: Formatting, Charts, Totals, Tables and Sparklines. 
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Formatting 

This category allows you to enhance data visualization by applying conditional formatting. The available 

options depend on the data type you’ve selected: 

For numeric data, you can use Data Bars, Color 

Scale, Icon Sets, Greater Than, and Top 10%, to 

highlight the relevant numbers in your dataset. 

 

 

 

For text values, you’ll have Highlight Duplicates, 

Unique Values, Cells That Contain, or Exact Match to 

identify and filter your data based on text criteria. 

 

 

 

For dates, you’ll be able to highlight the ones 

occurring Last Month, Last Week as well as 

Greater Than, Less Than, or Equal To a 

particular date. 

 

 

Charts 

Apart from the traditional ways to create charts in 
Excel, you can also use the Quick Analysis tool to 
insert a graph. While Quick Analysis provides a 
limited range of options, it intelligently suggests the 
most suitable chart types and makes the process 
faster. 

Based on your selected data, Excel’s Quick Analysis tool will display the chart types that are the best fit 
to represent your data graphically and help you visualize the patterns, trends, and relationships. You can 
hover over each graph type to see a preview of how it would look like in your worksheet. 

If the chart type you are looking for is not there, click on the More Charts option, which will open 
the Insert Chart dialog box, where you can select from a variety of other graph types, such as scatter 
plots, histograms, radar charts, and others. 

https://www.ablebits.com/office-addins-blog/make-graph-excel-chart-template/
https://www.ablebits.com/office-addins-blog/make-graph-excel-chart-template/
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This feature can help you create effective and attractive charts without spending too much time on 
formatting and customizing. However, if you want more control over the appearance and functionality 
of your charts, you can use the Chart Tools tab to access more advanced settings and features. 

Totals 

With Totals, you can easily calculate 

and display various summary statistics 

for your data, such as sum, average, 

count, percentage total, and running 

total. 

Depending on the type and format of 

the data in the selected range, you 

will see different options for applying totals. For example, if you only have text data, the only option 

available will be Count, which shows the number of cells with text values. 

Totals can be calculated for rows and columns. For vertical summaries in columns, you have several 

options in the blue color. For horizontal summaries in rows, click the right navigation arrow first, and 

then you can choose from the options in the yellow color that suit your data best. 

 

Tables / PivotTables 

Transform your tabular data into a formatted Excel 

table, equipped with filtering, sorting, and auto-

expanding features for professional data 

management. Additionally, you can insert a 

PivotTable in a new sheet using the selected data as 

the source for more comprehensive data analysis. 

 

Sparklines  

Sparklines are a great way to show data trends in a 

compact and elegant way. Insert these tiny in-cell 

charts to visualize patterns within your dataset, 

choosing from three types: Line, Column, or 

Win/Loss. 

Sparklines can help you highlight important 

information, such as seasonal variations, outliers, or progress towards a goal. They can also enhance the 

readability and aesthetics of your reports or dashboards, without taking up too much space. 

Sparklines (Detailed) 
Sparklines are miniature charts that fit into a single cell.  Use Sparklines to analyze and view trends in 

your data without creating an entire chart.  Sparklines have certain advantages over charts. If you have 

many rows of data, a traditional chart would not be appropriate to represent all of the rows, making 

https://www.ablebits.com/office-addins-blog/excel-sparklines-insert-change-use/
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relevant data difficult to find. But if you placed a sparkline on each row, it will be right next to its source 

data, making it easy to see relationships and trends for multiple data series at the same time. 

There are three types of Sparklines:  

o Line 

o Column 

o Win/Loss 

 

Line and Column work the same as line and column charts. Win/Loss is similar to Column, except it only 

shows whether each value is positive or negative instead of how high or low the values are. All three 

types can display markers at important points, such as the highest and lowest points, to make them 

easier to read. 

The following example shows how to create Sparklines in traditional way.   

To create Sparklines: 

Generally, you will have one sparkline for each row, but you can create as many as you want in any 

location. Just like formulas, it's usually easiest to create a single sparkline and then use the fill handle to 

create sparklines for the adjacent rows. In our example, we'll create sparklines to help visualize trends in 

sales over time for each salesperson.  

 

Let’s use SparkLines worksheet in the same workbook Intermediate Excel.xlsx to practice.  Source: 

GCFlearnfree.org 

 Select the cells that will serve as the source data for the first sparkline. In our example, we'll 

select the cell range B3:G3. 

 Click on Insert tab and Line in the Sparklines group as shown.  

 

 

 

 

 Create Sparklines dialog box will appear.  

Use the mouse to select the cell where the 

sparkline will appear, then click OK. In our 

example, we'll select cell H3, and the cell 

reference will appear in the Location Range: 

field.  The sparkline will appear in the 

specified cell: H3.  
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 Use Fill Handle to extend the sparklines to the 

rows below to see the trends on other sales data. 

Now the sparklines show clear trends in sales 

over time for each salesperson in our worksheet.  

Make the row height bigger to see the sparklines 

more prominent. 

 

To Modify Sparklines: 

Once you click on any cell that has sparklines, notice the Sparklines Toolbar appear on the ribbon with 

the Design tab. 

 

 

Here you can change: the sparkline type (Line, Column, Win/Loss), see high/low point markers, change 

color of sparklines and even marker color by using the commands.  

 In our example, let’s select the sparkline in cell H3 and click on High Point and Low Point 

check boxes in the Show group. 

 Select a different style that shows the green dot for the high point and the red 

dot for the low point to stand out.   

 

 Let’s change the sparkline type to Column by checking the Column 

from Type group.  

 

 

 Notice all the high column bars look the same even though the 

figures are not exactly the same.  To counter this drawback of the 

sparkline feature, click on the drop-down arrow under the Axis 

command.   
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 Notice both minimum and maximum values are “Automatic” for 

sparklines.  Change both to set as “Same for All Sparklines”.  

Now your sparklines should reflect the actual data on your 

spreadsheet. 

 

 

 

 

 

 

 

 

 


