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Microsoft Excel – Part 4 

 

Using templates – invoice, timesheets 
 

An Excel template is a predesigned spreadsheet that can be used to create new worksheets with the 

same layout, formatting and formulas. With templates, you don't need to reconstruct the basic 

elements every time as they are already integrated into the spreadsheet. You can get to Excel Templates 

upon opening the Excel program.  Select from keywords from the suggested searches or type in the 

search box to tap into online templates. 

 

For practice, let’s look for “Timesheet” and pick one from the result.  Click on “Create” button. 

Whenever you see text boxes with instructions that seem to be only partially seen, go to Data>Data 

Validation> click on Input Message tab to see the entire instruction.  These are helpful tips on how to 

use that particular predesigned spreadsheet. 

 

Giving a named range to cells 
 

A name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference, 

constant, formula, or table, each of which may be difficult to comprehend at first glance. For example, 

when you are adding up a range of cells that include first quarter sales, such as (C20:C30), compare how 

meaningful if you name that range as “firstquartersales” and use in the formula as follows: 

 

Regular formula to sum up:   =SUM(C20:C30) 

With the named range:  =SUM(firstquartersales) 
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Syntax Requirements for Naming Source: Microsoft.com 

Be aware of the following rules when you create and edit names. 

 

 Valid characters: The first character of a name must be a letter, an underscore character (_), 

or a backslash (\). Remaining characters in the name can be letters, numbers, periods, and 

underscore characters. 

 Cell references disallowed: Names cannot be the same as a cell reference, such as Z$100 or 

R1C1. 

 Spaces are not valid:   Spaces are not allowed as part of a name. Use the underscore 

character (_) and period (.) as word separators; for example, Sales_Tax or First.Quarter. 

 Name length:    A name can contain up to 255 characters. 

 Case sensitivity: Names can contain uppercase and lowercase letters. Excel does not 

distinguish between uppercase and lowercase characters in names. For example, if you 

created the name Sales and then create another name called SALES in the same workbook, 

Excel prompts you to choose a unique name. 

 NOTE: You cannot use the uppercase and lowercase characters "C", "c", "R", or "r" as a 

defined name, because they are all used as a shorthand for selecting a row or column for 

the currently selected cell when you enter them in a Name or Go To text box.  If your data is 

formatted as a Table, Excel automatically names that table by using a generic pattern 

name such as “Table 1”.  

 

Defining Names 

You can define names in three ways: 

 

1. Typing in the Name box in the left of the formula bar:  This is 

best used for creating a workbook level name for a selected 

range.  

 

Let’s use WeekTwo worksheet in the Intermediate Excel Skills 2.xlsx workbook to practice this concept. 

Assume you are trying to figure out how much total spent on Produce and Meat only.   

 Select cell ranges F4:F8 (cells for produce). 

 Click in the name box and type in “Produce”.  After typing, hit Enter button to complete. 
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 Select cell ranges F13:F15(cells for meat). 

 Click in the name box and type in “Meat”, then hit Enter. 

 Now you have two cell ranges named Produce, and Meat to use in 

formula. 

Let’s use these two names in a formula: 

 Select an empty cell, cell H2. 

 Start typing the =SUM formula “=SUM” followed by the open 

parenthesis and the letter “pr” to look for the name “Produce”. The 

name “Produce” will show up on from the Formula AutoComplete 

drop-down list.  Double-click on it to select it. [Alternatively, you can type in the entire word 

“Produce”.] 

 Type in comma “,” on keyboard to add “Meat” cells into the formula.  

Start typing the letter “me” and “Meat” will show up top on the list.  

Double-Click to include that in the formula and then type in close parenthesis “)” on 

keyboard to end the formula.  Then hit Enter.   

 Place close parenthesis and hit Enter. You will get the sum result of those cell ranges (F4:F8 

and F13:F15) in cell H2.  The answer should be 47.31. 

 

2. Select existing row and column labels: You can use the Create from Selection command 

(under Formulas tab in Defined Names 

group) to conveniently create names 

from existing row and column labels by 

using a selection of cells in the 

worksheet. Let’s use My List worksheet 

to practice the following concept. 

 

 On the My List worksheet, select the entire column A or 

block cell ranges A1:A10, and click on Create from 

Selection command.  Note: If you use the range of cells, 

you will have to extend the cell ranges later if you add 

more on the named list.  By using the entire column 

would give you a freedom of adding to or deleting from 

your list in later.  
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 Create Names from Selection box comes up.  Accept to use Top row 

as the name and click on OK.  Now you have the name “Category”, the 

same as your column heading. 

 Do the same for the columns with headings: Unit. 

 You should be able to see two names in the drop-down list on the name box.  If your 

column heading has more than one word, an “underscore” will be automatically placed 

between those words.  

 

3. Clicking on the Define Name in the Defined Names group will bring up New Name dialog 

box.   This is best used for when you want 

more flexibility in creating names, such as 

specifying a local worksheet level scope or 

creating a name comment.  

 In the same worksheet – My List, select 

the cell ranges C1:C19. 

 New Name dialog box will appear.   

 The name “Monthly_Expense” will 

appear (Note the underscore as names 

has space in between two words) in 

the Name box. 

 To specify the scope of the name, in 

the Scope drop-down list box, select Workbook or the name of a worksheet in the 

workbook. (Using the Workbook will allow you to use this name anywhere in the 

entire workbook while selecting a particular worksheet will only allow you to use 

the name for the chosen worksheet.) 

NOTE:  By default, names use absolute cell references. 

 Click on OK. 

Besides, typing the entire name out in the formula 

or selecting from the Formula AutoComplete as 

shown previously, you can use Use in Formula 

command in the Defined Names group.  This 

command will become active after you create a 

name.  Click on the drop-down arrow and select a defined name from a list 

available to include in your formula.   

 

We are going to use these names in formulas in creating drop-down list in next section. 
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Editing or Deleting Names 

You can use the Name Manager command in the Defined Names group to: create a new name, edit an 

existing name or delete a name. Note:  if you delete an existing name being used in a formula, deleting 

that particular name here will create an error in the cell that contains that formula. 

 

 

 

To delete, select a name by clicking on it. Then Delete.   

 To select more than one name in a contiguous group, click and drag the names, or press 

SHIFT and click the mouse button for each name in the group. 

 To select more than one name in a noncontiguous group, press CTRL and click the mouse 

button for each name in the group. 

 Click Delete. You can also press the DELETE key. Click OK to confirm the deletion. 

 

 

Drop-down lists 
You can make a worksheet more efficient by providing drop-down lists. It is especially useful when you 

want users to limit the data entry to what’s available in the list. Users can click an arrow and then click 

an entry in the list. Note:  You can create a drop-down list for a single cell or block of cells.  You can copy 

and paste a list.  You can also use the fill-handle to copy the list to adjacent cells like a formula.   

 

We have named a number of block of cells above (“Category”, “Unit”, “Monthly_Expense”) to use in our 

formula.   

 

Let’s use the Practice worksheet from same workbook to practice this concept.  Things to consider 

before creating a drop-down list. 

 It is recommended to create entries for your list in a row or a column in a separate 

worksheet in the same workbook.  (We have this done in our workbook.  The worksheet My 

List contains the lists we want to use.) 
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 You should sort your list the way you want it to appear. (Our lists are sorted.) 

 You should name the block of lists to use in the formula.  (We have named our lists.) 

 

 

Drop-down list in Settings: 

Let’s create a drop-down list for Category in cell A2 in 

Practice worksheet. 

 Click cell A2 in Practice worksheet.  

 Click Data >Data Validation in the Data Tools 

group.  

 On the Settings tab, in the Allow box, click List.  

 Check the In-cell dropdown box. 

 If it’s OK for people to leave the cell empty, check 

the Ignore blank box. 

 Click inside the Source box; click on Formula tab; 

Click on the arrow next to the Use in Formula and 

select “Category” from the list. 

 Now you will see an arrow next to the Cell A2 

from which you can select your category form the 

drop-down list. 

 You can copy and paste that list to as many rows 

below as you may fill in with other categories in 

those rows.  Copy Cell A2 up to row 9 before selecting any particular category either by 

copy-paste or using your fill handle. 

 Select Cell D2 to fill in with “Unit” from the list as explained in same steps above. Copy cell 

D2 up to row 9 too.  

 Select Cell I2 to fill in with “Monthly_Expense” from the list as explained in same steps 

above.  Copy cell I2 up to row 9 as well. 
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Now practice filling in data in a few rows beginning in row 

2 through 9 in Category, Unit and Monthly_Expense 

columns.  Your data should look like the data shown in 

rows 12 through 19 when finished. 

 

Input-Message:  When you want to caution the user 

before entering data or give reminder for a desired result 

in any particular cell, use this function. 

 Click Data >Data Validation in the Data Tools 

group.  

 Click the Input Message tab. 

 If you want a message to pop up when the cell 

is clicked, check the Show input message when cell is selected box, 

and type a title and message in the boxes (up to 225 characters). 

Example on the right show a reminder message appear in a 

particular cell to remind the limit of weekly grocery expense.  Try 

that in cell F10.  

 

 

Error Alert: 

This function is used to “stop” the user from 

inputting the invalid data.  You will have to use 

it in combination with the “settings” function.  

Assume, in this Practice sheet example that you 

want to limit the user not to exceed the 

monthly food expense of $750.  

You can place your limits as follows: 

 Let’s create the rule in Cell J9.  

 Click on Data>Data Validation. 

 In the Settings tab, select: 

o Whole number in the Allow 

section 
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o Less than or equal to in the Data section 

o Set the number to 750 as 

shown. 

 

 Next, click the Error Alert tab to 

enter your “error message” if an 

invalid data is placed in those cells.  

Under Style, using Stop will not let 

the user input any invalid data while 

Warning and Information will show 

the error message but will still let 

the user input invalid data.  Make 

sure the Show error alert after 

invalid data is entered box is 

checked to show the Error 

Message.  Enter the proper error message in Error message box.  Click OK. 

 Entering any data more than 750 will give you an error message in cell J9.   

 

 If invalid data is placed in those cells 

and if you had used the Stop under 

the Style to stop the user for doing 

so, a window will pop up and make 

the user correct the data until it 

meets the criteria.  

 

 

Creating conditions and formulas to format cells 
This command can give you a visual analysis of your raw data to detect critical issues and identify 

patterns and trends by applying formatting—such as colors, icons, and data bars—to one or more 

cells based on the cell value. To detect the trend correctly over a period of time, it is recommended 

to exclude the column or row with total values.  To learn this command, open Intermediate 

Excel.xlsx workbook and use the worksheet ConditionalFormatting. 

 

 We want to learn whether all sales people are meeting their monthly quota of $5000. We 

will apply the rule as - “If the value is greater than $5000, color the cell green." By applying 

this rule, you'd be able to quickly see which cells contain values over $5000.   

 Select the desired cells for the conditional formatting rule.  In our example, cells B3:G23. 

 From the Home tab, click the Conditional Formatting command. A drop-down menu will 

appear. 
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 Hover the mouse over the desired conditional formatting type, then select the desired rule 

from the menu that appears. In our example, we want to highlight cells that are greater 

than $5000. 

 

 

 A dialog box will appear. Enter the desired value(s) into the blank field. In our example, we'll 

enter 5000.  If you’d like to have a different formatting, click the drop down arrow and 

change the style to your choice such as “Red Text” or “Red Border”, etc. 

 

 The conditional formatting will be applied to the selected cells. In our example, it's easy to 

see which salespeople reached the $5000 sales goal for each month. 

Multiple Conditional Formatting Rules:  You can apply multiple conditional formatting rules to a 

cell range or worksheet, allowing you to visualize different trends and patterns in your data. 
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 For example, if you wanted to see 

how many cells in that selected 

data has unusually high data, use 

the color data bar to identify the 

cells.  The larger the data, the 

longer the color bar will be.  In our 

example, select the Purple Color 

Bar for the same cells B3:G23.   

 

 The new formatting with color 

data bar should apply over the 

previous conditional formatting of 

values more than $5000.  See 

below. 

 

 

To remove conditional formatting: 

 Click the Conditional Formatting command. A drop-down menu will appear. 
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 Hover the mouse over Clear Rules, and choose which rules you wish to clear. In our example, 

we'll select Clear Rules from Entire Sheet to remove all conditional formatting from the 

worksheet 

 For practice, click on Source Data 

worksheet in the same workbook and 

apply two rules to the entire Column 

E.  We want to apply $ to Order 

amount if the seller is from USA and 

British Pound £ if the seller for that 

line is from UK.  You can achieve this 

goal by applying two rules in Cell E2. 

Use the rule that says “Use a formula 

to determine which cells to format”. 

 Select the Cell E2. 

 Go to Conditional Formatting>New 

Rule> click inside the box with red 

arrow. 

 Type in =A2=”UK” as we want to set 

the rule if this cell A2 is equal to 

“UK”, we will assign British Pound 

symbol £ to Cell E2. 

 

 

 Click on the Format box and select 

Accounting>Look for English 

Pound symbol and click on OK.  
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 You will repeat this process for Cell E2 using the same steps above 

except we will assign the US$ symbol for Cell E2. There are now 

two rules in Cell E2.  We will copy these rules by using the Format 

Painter under the Home button. 

 

 

 Cell E2 should be set up for two rules; one for A2 being UK and the other for A2 being USA.  

 

 

 Select Cell E2 and double-click on the Format Painter brush. 

 Select Cell E3; Hold down Shift + Control + Down arrow key to select the remaining cells in 

Column E.   

 All those cells in column E now would show the British Pound symbol if their corresponding cells 

in column A are UK; and US$ symbol if their corresponding cells in column A are USA. 

Remember using the conditional formatting is to help you visualize data by providing visual cues to 

highlight patterns and trends or assign formats like we did.  The above example may not be a common 

practice in Excel, it may well exist if the data contains multiple countries in their respective currency 

formats.  

However, If you want any calculations out of data based on a criteria such as – if cell A2=”UK”, multiply 

the Cell E2 by 1.2 to give 20% commission on the sale, then you have to use IF function to accomplish 

that.  We will cover this in Advanced Excel chapters. 


