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Microsoft Excel – Part 2 
 

Paste special 
Under Copy and Paste options, there are a few commands that may come in handy.  To 

practice, open the ExcelPart2.xlsx workbook and select the PasteSpecial worksheet and 

select cell A1 through F15.  Click on Copy button under the Home menu or do Control + C 

on your keyboard to copy that selection. 

Now select cell H1; click the arrow under the Paste button and lay your mouse over each 

choices and look what the paste will look like without actually pasting the selection.  DO 

NOT CLICK THE MOUSE.  

Middle button on second row will not only paste your selection but also will retain 

source column width.  

Third button on second row will transpose your data. Transpose is used to switch the 

orientation of an array. It converts the vertical range to a horizontal range or vice versa. 

The first and second button on third row will paste your selection as fixed value so no 

formula will come along in the paste value. 

 

Basics of Formula & Using basic functions such as AVERAGE, SUM, and COUNT 
Just like a calculator, Excel has the ability to calculate numerical information using formulas. Excel 

can add, subtract, multiply, and divide. In this lesson, we'll show you how to use cell references to 

create simple formulas. 

Note:  All formulas start with the ‘=’ equal sign.  This is because the cell contains, or is equal to, the 

formula and the value it calculates. 

 

  

Addition + =10+5

Substraction - =10-5

Multiplication * =10*5

Division / =10/5
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Relative and Absolute Cell References: 
There are two types of cell references: relative and absolute. Relative and absolute references 

behave differently when copied and filled to other cells. Relative references change when a formula 

is copied to another cell. Absolute references, on the other hand, remain constant, no matter where 

they are copied. 

Relative Cell References:  By default, all cell references are relative references. When copied across 

multiple cells, they change based on the relative position of rows and columns. For example, if you 

copy the formula =A1+B1 from row 1 to row 2, the formula will become =A2+B2. Relative references 

are especially convenient whenever you need to repeat the same calculation across multiple rows or 

columns.  Let’s verify this by opening the Grocery worksheet in same workbook.   

 Select cell F2. 

 Enter the formula to find the total 

cost of row 2 for oranges.  (Total 

cost = Qty * Price) 

 The formula should be =C2*E2 as 

shown. 

 

 When we copied this formula from cell 

F2 to the lower cell F3 by using the Fill 

Handle, the cell reference changed 

based on the relative position of the 

row – in this case, Row 3.  So, the 

copied formula becomes =C3*E3  

 

 Select cell F3 again; use the Fill Handle, 

and copy the formula to all lower cells 

by dragging the mouse or double-

clicking the mouse.  Remaining rows 

now will have copied formulas with the 

cell references changed to the relative 

position of their row numbers.  

 

 

 Format column E (price column) and column F (total cost column) in accounting number 

format with $ sign. 

 

To Edit a Formula: 
When you need to edit an existing formula, you can do so in a number of ways.  Let’s assume we are 

going to edit our formula in Cell F2 in Grocery worksheet to include the markup of 10%.  That would 

require to multiply the original formula =C2*E2 with 1.1 as =C2*E2*1.1.  To do this, follow these steps. 
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 Double-click on Cell F2 

where we entered our 

original formula.  The 

cursor should be blinking 

at the end of the existing 

formula. (If not, move 

your cursor to the end of 

the existing formula.)      

 Then type in the multiplication symbol “*” 

and “1.1” as shown.   

OR 

 You can also click directly in the formula bar 

area to fix the formula. When finished, hit 

Enter key on your keyboard or select the 

Enter command  in the formula bar. 

 
 In either case the calculated value will show in Cell 

F2.           

 Undo your change by clicking on the undo 

command on quick access toolbar or Control+Z.    

 

Absolute Cell Reference: 
There may be times when you do not want a cell reference to change when filling cells. Unlike 

relative references, absolute references do not change when copied or filled. When you want to 

keep a row and/or column constant, use an absolute reference. 

An absolute reference is designated in a formula by the addition of a dollar sign ($). It can precede 

the column reference, the row reference, or both.  See the examples, below. 

Used generally more than 

 the other two formats. 

 

 

  



Excel Skills for Job Readiness 
Basic Excel Skills 2 Page 4 of 10 6/9/2025 

When writing a formula, select the cell you want to change and press the F4 key on your keyboard 

to switch between relative and absolute cell references. This is an easy way to quickly insert an 

absolute reference.  Let’s do the exercise below. 

o Select cell H1. 

o Click on the % sign in the Number group to indicate that you are formatting cell H1 

content as percentage. 

o Enter number 8 in cell H1. 

o You will see 8% in cell H1.  Consider this number as a discount you are going to apply to all 

rows in Total Cost column. 

o Select cell H2. 

o Enter the formula  =F2*H1 (by pointing and clicking on those cells). Then hit function key 

F4 before you hit the Enter button. Your formula would change from =F2*H1 to =F2*$H$1 

 

o Select cell H2 again.  Use the Fill Handle and copy the formula to the rows below.  

Examine each cell from H3 onward.  The first cell reference changes to the relative cell 

from F2 to F3, F4 and so on relatively.  However, the second sell reference $H$1 stays the 

same no matter what row you are looking at.   

 

Instead of typing in fixed numbers such as “10” or “5”, we will use cell references by pointing and 

clicking the cell we want to include in our formulas.  We will use the Formulas worksheet in the 

same workbook. 

 

1) In Cell F2, enter the formula to find the total cost for row 2. (Hint: Qty*Price =C4*E4). 

2) Once the answer in cell F2, copy the formula to all rows below. (Hint: double-click on fill-handle) 

3) Select cells F2:F10 and format as “Accounting”. 

4) Select cell A11 and Type in “Average Price”. 

5) Select cell E11 and find out the average price of the price column E by using the =AVERAGE 

under the  function drop down arrow. 

6) Select cell A12 and type in “Grand Total Cost”. 

7) Select cell F12and find out the Sum by using the  function. Note: Be sure to 

exclude average price Cell F11 in your summation. 
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8) Change row heights of row 1 and 12 to “30” by using Format>Row Height in Home>Cells group. 

9) Rename the Grocery worksheet as “Jan”. 

10) Follow instructor in this step to “Move” or “Copy” sheets into a New Workbook; make another 

copy of “Jan” worksheet in the new workbook and rename “Jan(2)” as “Feb”. 

11) Select both “Jan” and “Feb” worksheet.  

12) Select cell A3:F3. Change the Fill color to dark brown.  Change the Font color to white. 

13) Deselect from having both sheets and select only “Jan” sheet. 

14) Select cell A2:F12 and use “Linked Cell” Style. 

15) Finally, select columns C through E and change the column width to “10” by using the right click 

menu. 

 

Open WeekOne worksheet in the same workbook to practice creating arguments.   

 

AVERAGE Function: 

 In Cell E33 we want to calculate the average price per unit.  Select Cell E33. 

 Click on the drop-down arrow next to the Sum function in the Editing Group under the Home tab.  

Select Average. 

 The selected function will appear in the cell. If logically placed, the Average command will 

automatically select a cell range for the argument. In our example, cells E4:E32 were selected 

automatically.  In our case, there is no data in E31 and E32.  You can manually fix the argument 

directly in the formula bar area by using the backspace button on your keyboard and change the cell 

address from E32 to E30.   (OR you can use your mouse; click and drag to include the desired cell 

range into the argument as well.) 

 

 

 

 

 

 

 

 

 

SUM Function: Find out the sum of Total Cost column, Column F. 

 Click on Cell F34. 

 Select the Sum function from the list.  

 Fix the cell range in the formula bar using the backspace to change F33 to F30 since there is 

no data F31:F33.  

 Hit Enter.  The sum of Total Cost in our example is: $180.67. 
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COUNT Function: 

Finds the number of cells within a range of cells that contain values (numbers) in 

them. For example:   =COUNT(A10:A20) means count the numbers between cell A10 

through A20. 

 Select Cell C32. 

 Since the column includes numbers, we will select the Count function from 

the list.  We are using the Count Function here to count how many items 

are on the list.  We are NOT ADDING the items.   

 The formula appears =COUNT(C4:C31).  Fix the formula to include up to C30 only.   

 Hit Enter.  The count should give you 27 meaning there are 27 items where there is a 

number in the Quantity column.  Note the Count Function will count any number including 

zero.  But it will not count neither blank nor text. 

 

MAXIMUM Function: Find out the most expensive item in column E (Price Column) in cell E35 by using 

the =MAX(E4:E30).  The result should be: $6.99 for Coffee. 

MININUM Function: Find out the least expensive item in column E (Price Column) in cell E36 by using 

the =MIN(E4:E30).  The result should be: $.49 for Bananas. 

Multiple Argument Example:  A function can contain multiple 

arguments.  Each argument has to be separated by the “comma”. For 

example, in Cell F37, we want to find out total costs for all “Produce”, 

“Pasta” and “Supplies” selectively.  The function =SUM(F4:F8, F20:F21;F29:F30) will add the values of all 

the cells in the three arguments. The answer should be $40.19. 

Now Function: Displays the computer’s current date and time.  The formula will update the date and 

time next time the workbook is opened.  Select Cell C2 and type in =Now() 

Today Function:  Displays the computer’s current date.  The formula will update the date next time the 

workbook is opened. Select Cell B2 and type in =Today() 
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LEFT, MID, and RIGHT Formula in Excel 
Left returns the beginning characters of a string. Mid returns the middle characters of a string. Right 

returns the ending characters of a string. Use Phones worksheet to practice. 

Left( String, NumberOfCharacters ) 

Mid( String, StartingPosition [, NumberOfCharacters ] ) 

Right( String, NumberOfCharacters ) 

Let’s say you want to split the phone numbers into separate 3 columns.  Select Phones worksheet and 

look at the first row how the formulas are entered to get the left, mid, and right characters. 

Phone No.  Left Mid Right 

702-771-7149 702 771 7149 

 

=LEFT(A2,3) gave the first 3 digits from the left in Cell A2. 

=MID(A2,5,3)gave the middle 3 digits beginning from 5th position in Cell A2. 

=RIGHT(A2,4) gave the last 4 digits from the right in Cell A2. 

 

TRIM Formula in Excel 
Removes all spaces from text except for single spaces between words. Use TRIM on text that you have 

received from another application that may have irregular spacing. It deletes all leading, trailing and in-

between spaces except for a single space character between words. 

In Trim worksheet, select Cell B2 and enter =TRIM(A2).  Copy that formula to lower rows by using Fill 

Handle. 

 

Creating charts 
Charts allow you to illustrate your workbook data graphically, which makes it easy to visualize 

comparisons and trends.  Excel has several different types of charts, allowing you to choose the one that 

best fits your data. In order to use charts effectively, you'll need to understand how different charts are 

used.  They can be found under the Insert tab in the Charts group.  Recommended Charts will pick the 

most suitable chart for your data automatically.  However, you can select your own type.  Most 

frequently used charts are: 

 

Column Charts use vertical bars to represent data. They‘re 

most frequently used for comparing information. 

Line Charts are ideal for showing trends making it easy to see 

whether values are increasing or decreasing over time. 
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Pie charts make it easy to compare proportions. Each value is shown as a slice of the pie, so it's easy to 

see which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, 

allowing you to see a variety of information at the same time. Source: GCFlearnfree.org 

Let’s try a Pie chart by using the Grocery worksheet. You want to know how 

much % of the grocery budget is spent on what category.  First, you want to 

find the subtotals of each category. 

 Click anywhere inside the data. 

 Click on Data>Subtotal. 

 Select Sum for function and check Total Cost to subtotal on it. 

 Click on OK. 

 Click on Level 2 on top left corner to hide detailed rows for 

each category.  Your spreadsheet should only have two 

columns with data in it – Column A for Category and Column F 

for Total Cost.  

 Hold down the Control button on your keyboard and select 

Cells A1:A37 and F1:F37 as it appears in the picture shown. 

 

 Click on Insert Tab and select the 

3-D Pie from the Charts group.  

You will get a pie chart that is 

suitable to show the proportions 

of a whole. 
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Let’s enhance the chart by clicking on the Plus sign next to 

the chart to format Data Labels. Check Chart Title and Data 

Labels and uncheck the Legend.  

 Click on Data Labels arrow and click on More 

Options from the list. 

 

 

 

 

 

 

 

 

 

 

 

 On the right Format Data Labels pane, check boxes for Category 

Name, Percentage, and Show Leader Lines.   

 

 Your enhanced Pie Chart now has 

better labels to indicate how much 

percentage of your grocery money is 

spent on each category. 

 

 

 

 

 

 
For practice, use the same data (limit to two columns only – Category and Total Cost) and insert a 3D 

column chart. Play around to place some Data Labels, axis titles, chart titles, etc.   
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Using keyboard shortcuts to save time (Practice on your own) 
There are many shortcuts to use in Excel to save time.  A few notable commands are listed below. 

Workbook Shortcut Keys  

To create a new workbook Ctrl + N 

To open an existing workbook Ctrl + O 

To save a workbook/spreadsheet Ctrl + S 

To close the current workbook Ctrl + W 

To close Excel Ctrl + F4 

Cell Formatting Shortcut Keys  

To edit a cell F2 

To copy and paste cells Ctrl + C, Ctrl + V 

To italicize and make the font bold Ctrl + I, Ctrl + B 

To move to the next cell Tab 

To move to the previous cell Shift + Tab 

To select all the cells on the right Ctrl + Shift + Right arrow 

To select all the cells on the left Ctrl + Shift + Left Arrow 

To select all the cells above the selected cell Ctrl + Shift + Up Arrow 

To select all the cells below the selected cell Ctrl + Shift + Down Arrow 

To display find and replace Ctrl + H 

Row and Column Formatting Shortcut Keys  

To select the entire row Shift + Space 

To select the entire column Ctrl + Space 

To select the first cell in worksheet Ctrl + Home 

To select the last cell in worksheet Ctrl + End 

 

 


