In Access, Forms are used as an alternative to entering data into a table since they are often considered more user-friendly than a Datasheet view. A form can include fields from multiple tables, so you do not have to switch from one table to another when entering data. Access places the data you enter in the form into the proper table on which the form is based. You can also use Forms for searching, editing and deleting records. Remember any changes or deletions made to a record using a form will change the based table permanently.

Ways to Create Forms:

1. Open LibraryDatabaseAccess4.accdb Database.
2. In the Navigation pane, click on the Book Table and then click the Create tab.
3. Click the any of the following form button:
   a. **Form**: Creates a columnar form displaying a single record that includes all the fields. If the form is based on the table at the one side of a one-to-many relationship, the table from the one side of the relationship is displayed at the top of the form, and the related records from the table at the many side are displayed in the lower part of the form (Subform). Click on the Author Table and then click the Create tab. You can see two sets of Navigation buttons – the upper ones belong to the Author table (at the many side), and the lower ones belong to the Book table (at the one side). Upon closing, you will be asked to save the form (with name based on the table - Author). Say Yes and save the Author form.
   b. **Split Form**: Creates a columnar form on the top part and includes a table datasheet at the bottom part of the form. Do not save this form.
   c. **Multiple Items Form**: Creates a tabular form displaying multiple records. Do not save this form.
   d. **Blank Form**: Creates a blank form in Layout View – you can add any individual fields from available tables by using the drag and pull method on the grid or double-clicking.
e. **Datasheet Form**: Under More forms – creates a form and used in the same way as a table.

Forms created by using Form, Split Form, Multiple Form, and Datasheet Form are given the same name as the table or query the form is based on. Also, the fields appear on the form in the same order as they appear in the table structure or the query design grid.

**Working with Forms in Design View:**

- Open the *Book Form* in the Navigation Pane.
- You notice that in this form, each record is arranged in columns, with labels beside them. You will normally see a single record on the screen in the Form Layout View.
- Click on the Design View button on the Status Bar at the bottom right or Click the down-arrow under View button and select Design View.

On the above form in Design View, fields from corresponding tables show as a pair of control boxes. Though both sets of controls display the same text, the left textbox (unbound control) is a label and can be changed freely. The text in the right are bound to the corresponding table field and **changing the text in that box usually breaks this connection and creates an error.**
You can turn on/off the dotted grid lines on the form, the ruler, Form Header/Footer, and Page Header/Footer by toggling on those buttons in Show/Hide group under the Form Design Tools > Arrange Ribbon. **Please Note that if you have any controls in Form Header or Footer sections OR in Page Header or Footer Sections, by turning off those buttons you will delete those controls permanently.**

**Form Design Tools: The Design Ribbon**

Commands in the Font and Gridlines groups become active upon selecting control boxes to format the content inside or outside those boxes.
Let's create a form in Design View and try out some controls in the Controls group under the design tab. Click the Create tab and click on the Form Design button. Next, click on the Add Existing Fields button under the Tools group. Add the fields: LastName, FirstName, and Specialty (from the Author Table) and Title, Number of Copies, Publication Year and Price (from the Book Table). (Hint: Open the tables by clicking on the + sign then double-click on field names to add on the design grid.) Select all bound control fields (on the right) by using shift key then widen the field size by dragging one of the sizing handles in one field. All selected fields should be resized. Then deselect all fields by clicking off on an empty area. Next, select the brown square of the Label box (on the left) to select the Number of Copies box along and drag the Label box to the left to make space between the label and content box on the right. Then select all label boxes (by clicking on them individually while holding down the Shift key); go to the Arrange Ribbon and click on the Left Align button to shift all label boxes to be left aligned with the Number of Copies label box. Use any of the text control box under Font Group to align the text inside if desired. Save this form as “Custom Author”. You may want to set the properties of Allow Additions, Allow Deletions, and Allow Edits to “No” under the Data Tab so the user cannot add, delete, or edit the data in this form.

Form Controls: Clicking on them find the location on the form where you want to create the object; use the mouse to draw a rectangle the desired size of the control. Commonly used controls are:

Unbound Text box: An unbound text box is not connected to a field in a table or query. You can use an unbound text box to display the results of a calculation or to accept input that you don’t want to store directly in a table. Note: Access also places a label to the left of the text box, so leave some room to the left of the pointer for the label. You can reposition the label and the text box later. You can also delete the label by clicking it and then pressing DELETE. You must add the fields on the form first before you use those fields to create a calculation or a new field such as Full Name. Try using this to create an unbound box for first name and last name fields by typing: =[firstname] & " " & [lastname] in the box.
**Label Toolbox:** A control that displays descriptive text, such as a title, a caption, or instructions, on a form or report. Labels may or may not be attached to another control. Click on the **Arrange** Ribbon under **Form Design Tools** Ribbon. Turn the Form **Header/Footer** button on. Place the **Label** button in the Header area. Type in the label “Our Collections” and format the label any color, size and Special Effect of your choice under the **Format** tab in Property Sheet.

**Button Toolbox:** Use to perform actions, such as finding a record, printing a record, or applying a form filter. In the Form Footer area, draw a **Button** command and select **Form Operations** from the Categories under the **Command Button Wizard** window. Select **Close Form** under the Actions window and click on Next. Accept the Exit Doorway picture to apply to the button and click Next. Give an appropriate name “Close Form” and click Finish. You should see this image on your form. You can use this button to close the form as an alternative to clicking on the “X” on the top right. Say “Yes” to save your new button.

**List Box:** Displays a scrollable list of values. When a form is open in Form view or when a data access page is open in Page view or Microsoft Internet Explorer, you can select from the list to enter a value into a new record or to change the value in an existing record.

**Combo Box:** Combines the features of a list box and a text box. You can type in the text box or select an entry in the list box to add a value to an underlying field. *More on Page 9 of this handout.*

**Subform/Subreport:** Use to display data from more than one table on a form or report. For example, if you want to include Publisher information in a subform on your **Custom Author** form, pull in the **Company Name** field first in the detailed area by using **Add Existing Fields** command. Make that field “not visible” under the **Format** tab. Then, click on the **subform/subreport** command in the ribbon. **Subform Wizard** will open. Select **Use Existing Tables and Queries** in first window and click Next. From the Table/Queries dropdown arrow, select the **Publisher** Table. From Available Fields, select **Company Name** and **Country** fields to the right window. Click Next in the next window. Accept the subform name **Publisher Subform** and click Finish. Adjust the subform window size to display all fields inside as shown above. You will see the subform named **Publisher Subform** added in the navigation pane under Forms category.

**Image Toolbox:** Use for displaying a static picture on a form or report. You can’t edit the image inside Microsoft Access after you’ve added it to a form or report since a static picture is not an OLE object.

Click on the **Add Existing Fields** button to add additional fields to the form from the table the form is based on. Click on the **Property Sheet** button to set properties of each section of the form (header, detail, footer), and each control on the form.
Saving Your Form: If you close the form you just created, Access will offer you to save the form in the default form name (normally the same as the Table name you based the form on). You can use the Save As function under the Office Button and give it a different name.

Property Sheet:

There are so many different properties available for each control box. However, the short cut buttons are easier using than using the property sheet. For example, changing the background color of a text box is much easier using the Fill Color button on the Design Ribbon than using the Format command to change the Back Color on the Property Sheet. If you wonder what a particular property is used for, the easiest way to find out is to select the property and then look at the Access status bar (at the bottom left). There you will find information that provides quick help on what the property does.

Many properties inherit underlying properties from the original table. In the example on the right, the Row Source line under the Data tab in the SubjectID field indicates that the original Book Table contains the LookUp field so Access creates a combo box for it on the form.

You can sort the values in the combo box just like you would do in a query. To do that, click on the Build button next to the Row Source property row. The SQL Statement Query Builder window will open. Use Ascending or Descending to sort.
Working with Form Controls:

Any item or object on a form, such as a field name, a field value, and the form title, is called a control. By using a form wizard, it will take care of arranging and sizing the controls to make a form according to the selections you selected in the wizard. If you want to modify a form, you can do so in Design view by:

- Moving and sizing controls
- Changing control properties
- Changing the appearance of controls with borders, shading, and text effects such as bold and italics
- Inserting new controls
- Organizing controls using group boxes

Modifying a Control's Type: You can right click on any control and click Change to in the pop-up menu. Any relevant alternatives will be visible on the list that appears. For example, if you right-click on the Lending check box and click on Change To, the Toggle button and Option buttons are your other alternatives. Similarly, combo boxes are interchangeable with List boxes and text boxes. There are also other short-cut menus you can use to format that particular control box. Those short cut commands are also available under the Arrange Tab under the Form Design Tools Ribbon.

Types of Form Controls:

To create a control, as explained on the page number 4 of this handout, you click the control button for the kind of control you want to create and then drag the pointer over the area where you want the control to appear in the Design View.

1. **Bound Controls**: They are fields of data from a table or query. They are bound to the data source. A form must contain a bound control of each field that you want to appear on the form. You cannot create a calculation in a bound control.

2. **Unbound Controls**: They are controls that contain a label or a text box. You will typically use these controls to identify other controls or areas on the form. You can create calculations from an unbound control.

3. **Calculated Controls**: They are any values calculated in the form, including totals, subtotals, averages, percentages, etc. The data is derived from an expression rather than from a table or query.

Essential Controls from the Property Sheet:

**Data Tab:**

**Control Source**: It depends on your selection. It will read **Control Source** if this is the field to which the control is bound, such as the **AuthorID** field (bound control) in the example. It will read **Record Source** if your selection is for the whole form to indicate which table the form is based on. In the event, where there is a calculated control, this is the expression that is being calculated.
The exact properties available depend on the object you have selected on the form. Take a look on the right for where to click to activate specific control properties.

**Allow Additions/Deletions/Edits:** Click on the Form Control button and you should see these options under the Data tab. By default, they are set “Yes” to allow the user to add/delete/edit the data. Change these to “No” to create a form for the purpose to look up information only.

**Data Entry:** Also under the Data tab, by selecting “Yes” on Data Entry will hide the existing records but will allow users to add new records with no chance of changing the older ones.

**Format Tab:** You can apply any available format to any selected field, such as background color, visible or not, size or border, limit of decimal numbers or currency format, etc.

**Creating a Calculated Control in a Form:** Assume you want to create a total cost field on the Book Form. Add an unbound text box at bottom of the Detail area. Click the expression builder button next to the Control Source dropdown arrow. In the Expression builder dialog box, type in: \(=\text{[Number of Copies]} \times \text{[Price]}\)

You can click inside the Label box to and type “Total for this Title”.

**Creating a Subtotal Field in a Form:** You can easily create any calculated field into a Subtotal field on the form by just modifying the expression in the control box to sum up. Assume you wanted to show the Total Cost of Library Holdings on the same Book Form in the Footer Section. Extend the Footer Section and copy the Calculated Field above from the Detailed Section into the Footer Section. In the Expression box, change the expression to add a function to sum up as shown below:

Make sure you place the original expression in parentheses “()”. Change the Label box to read “Total Cost of Holdings”. Change the Text Align to Right and change the Format to Currency in the Property Sheet on both calculated fields (in the Detailed Section) and Subtotal field (in the Footer Section) so that the costs show up in US currency right aligned in the boxes.
Practice with Combo Box

Our original Book Form created by the Form Button does not include Lookup values for AuthorID and PublisherID fields. This makes it difficult for filling in new book titles written by an existing author and an existing publisher already in the database. Since we created a Lookup value in the SubjectID field of the Book Table, we can use one of existing subjects from a drop-down lookup value. However, we do not have similar arrangements for the AuthorID and the PublisherID. We can create a lookup values for these two fields by simply creating some combo boxes. Follow these steps to create a new form to fill up new book titles.

1. Make a copy of the Book form and name it as New Title form.
2. Open New Title form in the design view.
3. Click on the Combo box button in the Controls group once.
4. Drag the mouse onto an empty area of the form and draw a combo box. That will activate the Combo Box Wizard.
5. Select the first radio button: “I want the combo box to look up the values in a table or query.” Click Next.
6. Select the Author Table in the next window and click Next.
7. Select AuthorID, LastName, and FirstName fields into the Selected Fields pane in the next window. Click Next.
8. Sort the fields in ascending order by the AuthorID in the next window. Click Next.
9. Uncheck the box to hide the key column in the next window and make adjustments to all three fields by double-clicking on column margins (just like in the Excel). Click Next.
10. In the next window, select AuthorID field as a unique identifier for the entire row values and click Next.
11. Select the second radio button to save the values in the AuthorID field in the next window. Click Next.
12. Give the name “AuthorID” and click Finish.
13. Select the pair of the combo box you just created by clicking on individually while holding down the shift button.
14. Drag the pair onto the original AuthorID label and text box and drop on it. The original AuthorID label and text box pair will be shifted one level down.
15. Then, click the original AuthorID either on label and text box and hit the Delete button on your keyboard to remove that pair. View the form in the Form view. Adjust the widths of the columns inside the AuthorID drop-down box by using the Column widths values under the format tab. While in the field, activate the Property Sheet and click on the Other tab. Change the name from a generic Combo# to AuthorID.
16. Follow steps 3 through 15 above to create a combo box for the PublisherID field. Use PublisherID and Company name fields from the Publisher Table.
17. You should see the field values displayed in the combo box as below.
Using the Form Wizard in creating a form (one-to-many relationship) paired with a Subform:

When a one-to-many relationship exists in your database, you can create a form that includes both the main form that will represent the “one” side of the relationship and a subform which will represent the “many” side of the relationship. A subform is a form that is inserted in another form. A form/subform combination is sometimes referred to as a hierarchical form, a master/detail form, or a parent/child form. By using the Form Wizard, you can customize your form to include fields from your selected data sources (tables or queries, and then specific fields).

Let’s create a custom form using the Form Wizard. Select tables in parenthesis for this practice.

1. Click the Create tab.
2. Click the More Forms button, and then click Form Wizard.
3. Click the list arrow for choosing a table or query on which to base the form, and then click the name of the table (Subject Table) or query you want. Remember, you can select more than one table or query.
4. Specify the fields (Select Subject Name) that you want included in the form by double-clicking the fields or clicking on button. You may click on button to include all fields. Likewise, use button to remove a field or << to remove all fields.
5. Repeat steps 3 and 4 again to select the Book table (Select Title, Number of Copies, and Publication Year fields).
6. Click Next to continue.
7. Determine the arrangement and position of the information on the form. Access will place the field from the one side of relationship in the main form and the other fields in the subform. Click Next.
8. Specify the style of the form which defines the formatting and final appearance of the form. The **Tabular** format shows fields in each record arranged horizontally with headers on the top. One advantage of basing a subform on a form object is that you can add calculated fields (such as the subtotal field) to the subform. The Tabular format allows placing the calculated field in the Footer Section of the subform. The **Datasheet** format is similar to a spreadsheet. (A datasheet is not as customizable as a subform; for example, you cannot add a calculated field to a datasheet.) Select the **Tabular** format for this practice and click on **Next**.

9. Select an AutoFormat style of your choice in the next step and click on the **Next** button.

10. You can accept the name (normally based on the table names) or change names of the form and the subform. Click **Finish** and your form will be displayed in Form View. See your finished form on the next page.
11. In step 8, while selecting a **Tabular** format on your subform, the ability to be able to create a calculated field in the footer section of the subform is mentioned. Let’s create one.

12. Open the finished form in Design View. On the Book Subform, pull in the Text box control button into the footer section area and type in the subtotal formula:

\[
\text{Total for this Subject:} = \text{Sum([number of copies] *[price])}
\]

change the format of that control box to “currency”. Change the label text box on the left to read “Total for this Subject:”. Your added calculated field on your subform should look like this:

Once you created a main form paired with a subform, you can also open the subform in its own window by double-clicking on the Sub Form in Objects pane. In Design View of the main form, you can click on the subform, you can resize the entire subform or edit any controls inside the subform such as you would do on the main form. Open the Book Subform and set “No” to Allow Additions/Edits/Deletions under the Data tab in the Property Sheet.
Navigating on a Form:

1. Use the Tab key to move through fields in a record. Use the Shift-Tab key to move backward. If this order is not appropriate you can change it later.
2. Use the Navigation buttons at the bottom to go through the records, just as you would in the table. Or you can type a number in the record number field to go to a specific record.
3. You can also type in a search term in the Search box and hit enter to go through the records that include your search term.
4. Click a New Record button to get a blank form on which to enter new data on the form where you can enter a new record.
5. You can use horizontal and vertical scroll bars to display parts of the form that are not displayed in the window.

View Options on Forms:

Three types of Views available under View tab on the Ribbon or Status Bar at the bottom.

1. **Layout View**: It allows you to view information associated with the record and make design changes to the form.
2. **Form View**: It allows you to view all the information associated with a record and enter data in it to change the based tables.
3. **Design View**: It allows you to modify the form’s design. It gives you a more detailed view of the structure of the form. You can view the Header, Detail, and Footer Sections of the form.

Layout View resembles the actual data form and gives an approach to re-arrange fields just like in MS Word Layout view approach. In Design View, to make it easier to enter and maintain data, you can also include instructions and guidance on the form as ControlTip Text so that a user of the form knows how to complete it. Though you do not see the underlying data of the form while creating, Design view allows easier ways to resize field boxes and move them.

The Form Arrange Ribbon:

This ribbon contains tools for formatting, sizing, and arranging controls on your form.
Control Layouts: Control layouts are useful because they let you quickly align and position groups of controls at the same time, without first having to select each control. There are two types of Form layouts.

1. When you create a single form, Access uses stacked control layouts by default. In a stacked layout, the anchoring feature moves and stretches controls vertically and horizontally. All text boxes and label boxes are treated as one big group and you can apply changes and sizes together. Let’s create a single form by using the Form Wizard.
   a. Click on Create tab and select the Form Wizard button under the More Forms button. You will bring up the Form Wizard window.
   b. Select Table: Author in Table/Queries option. Double-click the LastName, FirstName, DateofBirth, Nationality, and Specialty fields to include those fields on your form. Click on the Next button.
   c. On next window, select columnar layout and click on the Next button.
   d. Select a style on next window and click on the next button.
   e. Give the title as Author1 for your form and click on Finish.

2. Open the Author1 Form in Design View (this is in stacked layout View) and click on the group selection button on the top left to select all controls on the form. Use the Control Margin and Control Padding commands to resize inside and outside spacing as you wish. Use the Anchoring command to see how the entire groups of controls configure depending on the anchor position. Click on an empty location to de-select all controls. If you desire to separate the stacked layer of these boxes, click on any individual pair (label and text boxes) while holding down the shift key. Then, click on the Remove button from the Control Layout group. Then you can pull the pair to the desired new location. Or you can group those boxes together by using the group button to move them in a group. Use the ungroup button to ungroup them if you need to.

By default, the controls on a form stay anchored to the upper-left corner of the form, and do not resize when you resize the form. To change this behavior, you can use the Anchoring command. For example, you can configure a text box so that it stretches down and to the right as the form becomes larger. This lets you see more text in the control.
3. On *multiple-item forms (continuous forms)*, Access uses *tabular control layouts* by default. In a tabular layout, the anchoring feature only moves and stretches controls vertically. For example, the *Stretch Down and Across* anchoring option only causes a control to stretch across, not down. Open the *Book* Subform in Design View. In it, you will notice that the field labels are in the page header and the text boxes are in the Detail area. Click the label or the text box of the *Last Name, First Name, and Publication Year* individually and try to resize to a smaller size on each. You will notice that the resizing happens vertically. You can resize more than one pair at a time by using the Shift key while selecting individual label boxes.

![Diagram of tabular control layout](image)

**Changing the Tab Order and Practice Adding New Data on a Form:**

1. Open the *New Title* form in Design View.
2. Click on the *Arrange* tab and select the *Tab Order* button in the *Control Layout* group. Tab Order dialog box will pop-up. According to the tab order as of now, you will land in the *Number of Copies* cell if you hit the tab key after filling in the *Row Number* field. Let’s change it.
3. Select the *Shelf Number* field by pointing to the grey area on the left; hold down your left mouse button until you see the grey square. Then drag the entire field right below *Row Number* field until you have *Row Number* and *Shelf Number* fields next to each other. Click *OK*. Put the form in the Form View.
4. Click the record navigation new button to add the following information.
   a. ISBN: 978007 1493277
   b. Title: SharePoint Server 2003
   c. AuthorID: 13
   d. PublisherID: 1
   e. SubjectID: Computing
   f. Row Number: 12
   g. Shelf Number: 3
   h. Number of Copies: 1
   i. Publication Year: 2006
   k. Lending: yes by checking in the box.

   Upon clicking the next record button, the *Total Cost* field and *Total Cost for Holdings* fields should automatically get updated. Not only that, the *Book* Table the form is based on now has a new record of this book. Open the *Book* Table and see the last record.